aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@4pi.com>2011-10-10 23:37:54 -0400
committerdavilla <davilla@4pi.com>2011-10-10 23:37:54 -0400
commit7e7a13cd2d11a449c3413bbe82abaff86be8c96d (patch)
tree0e3a7d6f584dab78c61c8514d6c2e2ce93c0062e /configure.in
parent75763e18b6b85f2656e6f98a6242d8dc540ac699 (diff)
[ios] changed/fixed, detect skin.touched. if present enable packing it and use for default skin if permitted by code ifdef. fixed also check when xcode does copy root files for packaging into xbmc.app. fixed errors in copy root files, skin.touched has background not backgrounds dir
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 679ff467cb..5505eaed19 100755
--- a/configure.in
+++ b/configure.in
@@ -967,6 +967,17 @@ else
DISABLE_PROJECTM=0
fi
+# skin touched
+use_skin_touched=no
+if [[ -f "addons/skin.touched/addon.xml" ]]; then
+ use_skin_touched=yes
+ USE_SKIN_TOUCHED=1
+ AC_DEFINE([HAS_SKIN_TOUCHED], [1], [Whether to build skin touched.])
+else
+ USE_SKIN_TOUCHED=0
+fi
+
+
# libRTMP
if test "$use_librtmp" != "no"; then
AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],,
@@ -1588,6 +1599,12 @@ else
final_message="$final_message\n ProjectM:\tNo"
fi
+if test "$use_skin_touched" = "yes"; then
+ final_message="$final_message\n Skin Touched:\tYes"
+else
+ final_message="$final_message\n Skin Touched:\tNo"
+fi
+
if test "$use_x11" = "yes"; then
final_message="$final_message\n X11:\t\tYes"
else
@@ -1860,6 +1877,10 @@ OUTPUT_FILES="Makefile \
xbmc/peripherals/devices/Makefile \
lib/libcec/Makefile"
+if test "$use_skin_touched" = "yes"; then
+OUTPUT_FILES+=" addons/skin.touched/media/Makefile"
+fi
+
# Line below is used so we can use AM_INIT_AUTOMAKE. The corresponding
# .dummy.am does nothing.
AC_CONFIG_FILES([.dummy])
@@ -1876,6 +1897,7 @@ AC_SUBST(BUILD_DVDCSS)
AC_SUBST(DISABLE_GOOM)
AC_SUBST(DISABLE_RSXS)
AC_SUBST(DISABLE_PROJECTM)
+AC_SUBST(USE_SKIN_TOUCHED)
AC_SUBST(USE_EXTERNAL_FFMPEG)
AC_SUBST(PYTHON_VERSION)
AC_SUBST(OUTPUT_FILES)
@@ -1915,6 +1937,7 @@ AC_SUBST(USE_LIBUSB)
AC_SUBST(USE_LIBCEC)
AC_SUBST(USE_EXTERNAL_LIBCEC)
+
# pushd and popd are not available in other shells besides bash, so implement
# our own pushd/popd functions
XB_DIRSTACK="$PWD"