aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2015-01-03 14:31:02 +0100
committerMemphiz <memphis@machzwo.de>2015-01-08 21:59:03 +0100
commitf73653d62b09db8cab7662ae7c4b2dab596b4ab0 (patch)
treea4ba28c9bc510768458040456afebaeab00aed5c /configure.in
parent145112899a48560df8146376542adfddd3adf79f (diff)
[configure] adjust to texturepacker and squish in depends
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 29 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index dd7338efdc..786b06f8db 100644
--- a/configure.in
+++ b/configure.in
@@ -2174,13 +2174,39 @@ else
fi
if test "x$use_texturepacker" != "xno"; then
- final_message="$final_message\n TexturePacker:Yes"
- USE_TEXTUREPACKER=1
+ AC_PATH_PROG([TEXTUREPACKER], [TexturePacker], ["none"],
+ [$PATH$PATH_SEPARATOR${abs_top_srcdir}/tools/depends/native/TexturePacker/bin])
+ if test "$TEXTUREPACKER" = "none"; then
+ make -C ${abs_top_srcdir}/tools/depends/native/TexturePacker
+ TEXTUREPACKER="${abs_top_srcdir}/tools/depends/native/TexturePacker/bin/TexturePacker"
+ fi
+ if test -x "$TEXTUREPACKER"; then
+ final_message="$final_message\n TexturePacker:Yes"
+ USE_TEXTUREPACKER=1
+ else
+ if "x$use_texturepacker" = "xyes"; then
+ AC_MSG_ERROR("Texturepacker not found")
+ else
+ AC_MSG_NOTICE("Texturepacker not found")
+ USE_TEXTUREPACKER=0
+ final_message="$final_message\n TexturePacker:No"
+ fi
+ fi
else
final_message="$final_message\n TexturePacker:No"
USE_TEXTUREPACKER=0
fi
+# we don't compile with default upstream squish, so we use our own one
+# even on non unified deps platforms
+if test "$cross_compiling" != "yes"; then
+ export PKG_CONFIG_PATH="${abs_top_srcdir}/tools/depends/native/libsquish-native/squish-install/lib/pkgconfig:$PKG_CONFIG_PATH"
+fi
+PKG_CHECK_MODULES([SQUISH], [squish],
+ [INCLUDES="$INCLUDES $SQUISH_CFLAGS" LIBS="$LIBS $SQUISH_LIBS"],
+ AC_MSG_ERROR("squish not found"))
+
+
if test "$use_mid" = "yes"; then
final_message="$final_message\n MID Support:\tYes"
SDL_DEFINES="$SDL_DEFINES -DMID"
@@ -2466,7 +2492,6 @@ OUTPUT_FILES="Makefile \
lib/libXDAAP/Makefile \
lib/cmyth/Makefile \
lib/libhdhomerun/Makefile \
- lib/libsquish/Makefile \
lib/cximage-6.0/Makefile \
lib/libUPnP/Makefile \
xbmc/DllPaths_generated.h \
@@ -2492,7 +2517,6 @@ OUTPUT_FILES="Makefile \
tools/Linux/${APP_NAME_LC}-xsession.desktop \
tools/Linux/FEH.py \
tools/Linux/FEH-ARM.py \
- tools/TexturePacker/Makefile \
tools/EventClients/Makefile \
tools/EventClients/Clients/OSXRemote/Makefile \
xbmc/peripherals/bus/Makefile \
@@ -2599,6 +2623,7 @@ AC_SUBST(HAVE_LIBPULSE)
AC_SUBST(USE_XRANDR)
AC_SUBST(USE_ALSA)
AC_SUBST(USE_TEXTUREPACKER)
+AC_SUBST(TEXTUREPACKER)
AC_SUBST(USE_AIRTUNES)
AC_SUBST(USE_LIBUDEV)
AC_SUBST(USE_LIBUSB)