aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2015-02-20 07:45:16 +0000
committerwsnipex <wsnipex@a1.net>2015-02-20 07:45:16 +0000
commit7c8ce2f3dcdeb92c6a4031c4549714420d367032 (patch)
tree15a514849fa5a743a7cd913d026f768675048b8a /configure.in
parentd6f8a65589ef3b11a8286f18ba4f1083765a48dc (diff)
[configure] make sure the gcc-4.9 SSE workaround is only enabled on x86
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 13 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 4439eb66c5..1a057af796 100644
--- a/configure.in
+++ b/configure.in
@@ -591,20 +591,6 @@ OBJDUMP="${OBJDUMP:-objdump}"
READELF="${READELF:-readelf}"
NM="${NM:-nm}"
-# Workaround a build issue on i386 with gcc 4.9:
-# including <algorithm> pulls in SSE intrinsics.
-# possible GCC bug? ideas welcome
-if test "$GCC_CXX" = "yes"; then
- GCC_VERSION=$($CXX -dumpversion)
- GCC_MAJOR_VER=$(echo $GCC_VERSION | awk -F"." '{print $1}')
- GCC_MINOR_VER=$(echo $GCC_VERSION | awk -F"." '{print $2}')
-
- if (test "$GCC_MAJOR_VER" -eq "4" && test "$GCC_MINOR_VER" -ge "9") || (test "$GCC_MAJOR_VER" -gt "4"); then
- CXXFLAGS="$CXXFLAGS -msse"
- AC_MSG_NOTICE("detected gcc version $GCC_VERSION - enabling SSE")
- fi
-fi
-
# host detection and setup
case $host in
i*86*-linux-android*)
@@ -625,6 +611,19 @@ case $host in
use_cpu="i686"
fi
USE_STATIC_FFMPEG=1
+ # Workaround a build issue on i386 with gcc 4.9:
+ # including <algorithm> pulls in SSE intrinsics.
+ # possible GCC bug? ideas welcome
+ if test "$GCC_CXX" = "yes"; then
+ GCC_VERSION=$($CXX -dumpversion)
+ GCC_MAJOR_VER=$(echo $GCC_VERSION | awk -F"." '{print $1}')
+ GCC_MINOR_VER=$(echo $GCC_VERSION | awk -F"." '{print $2}')
+
+ if (test "$GCC_MAJOR_VER" -eq "4" && test "$GCC_MINOR_VER" -ge "9") || (test "$GCC_MAJOR_VER" -gt "4"); then
+ CXXFLAGS="$CXXFLAGS -msse"
+ AC_MSG_NOTICE("detected gcc version $GCC_VERSION - enabling SSE")
+ fi
+ fi
;;
x86_64-*-linux-gnu*|x86_64-*-linux-uclibc*)
ARCH="x86_64-linux"