aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorelupus <elupus@svn>2010-08-26 23:25:48 +0000
committerelupus <elupus@svn>2010-08-26 23:25:48 +0000
commita75e23544612c4e519d5e22f0ca2980e782138f7 (patch)
tree71c3aae7f7dc50ff1e3cf0ab403324837c793b93 /configure.in
parent82230a7108cee6d26c6f102ecde595dbadf06a73 (diff)
backport: bluray plaback support based on libbluray
r33147 [WIN32] r33145 for VS2010 - bluray support r33145 [WIN32] build xbmc with support for libbluray r33144 [WIN32] added libbluray headers, dll and how to build the dll r32602 changed, install libbluray into /usr/lib on Linux because XB_FIND_SONAME can't find it in /usr/local/lib, revert later r32564 add libbluray download/makefile r32562 opps, copy/paste monster bites again r32561 changed, dyload libbluray instead of static linking it r32398 cleanup: leftover from libbdnav removal r32329 fixed: yet another leftover from libbdnav removal r32326 fixed: removed now deleted libbdnav from build system r32319 removed: old libbdnav sources aswell as the old mpls playback code. r32261 added: support stacking with libbluray r32236 fix compile error is HAVE_LIBBLURAY not defined r32234 changed: generalize the SeekTime inputstream interface r32233 changed: make chapter support from input stream a general interface r32232 added: support for using libbluray to play bdmv files (index.bdmv or *.mpls) git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/Dharma@33193 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in92
1 files changed, 58 insertions, 34 deletions
diff --git a/configure.in b/configure.in
index 39da1eb653..b86fc198c3 100644
--- a/configure.in
+++ b/configure.in
@@ -14,6 +14,29 @@ tolower(){
echo "$@" | tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz
}
+# check for library basenames
+AC_DEFUN([XB_FIND_SONAME],
+[
+ AC_MSG_CHECKING([for lib$2 soname])
+ $1_SONAME=$( $CC -print-file-name=lib$2.so | \
+ while read output; do objdump -p $output | \
+ grep "SONAME" | \
+ sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
+ if [[ -z "$$1_SONAME" ]]; then
+ AC_MSG_RESULT([no])
+ if test -z "$3" || test "x${$3}" = "xyes"; then
+ AC_MSG_ERROR([Unable to determine soname of lib$2 library])
+ else
+ AC_MSG_WARN([Unable to determine soname of lib$2 library])
+ $3=no
+ AC_MSG_WARN([lib$2 support disabled])
+ fi
+ else
+ AC_MSG_RESULT([$$1_SONAME])
+ AC_SUBST($1_SONAME)
+ fi
+])
+
# General message strings
configure_debug="ERROR: this is a configure debug statement"
missing_library="Could not find a required library. Please see the README for your platform."
@@ -246,6 +269,12 @@ AC_ARG_ENABLE([liba52],
[use_liba52=$enableval],
[use_liba52=no])
+AC_ARG_ENABLE([libbluray],
+ [AS_HELP_STRING([--enable-libbluray],
+ [enable libbluray support])],
+ [use_libbluray=$enableval],
+ [use_libbluray=auto])
+
AC_ARG_WITH([lirc-device],
[AS_HELP_STRING([--with-lirc-device=file],
[specify the default LIRC device (default is /dev/lircd)])],
@@ -549,6 +578,29 @@ PKG_CHECK_MODULES([VORBISENC], [vorbisenc],
[INCLUDES="$INCLUDES $VORBISENC_CFLAGS"; LIBS="$LIBS $VORBISENC_LIBS"],
AC_MSG_ERROR($missing_library))
+# check for libbluray
+AS_CASE([x$use_libbluray],
+ [xyes],[
+ PKG_CHECK_MODULES([LIBBLURAY],[libbluray],[use_libbluray="yes"], AC_MSG_ERROR($missing_library))
+ ],
+ [xauto],[
+ PKG_CHECK_MODULES([LIBBLURAY],[libbluray],[use_libbluray="yes"], [use_libbluray="no"])
+ ])
+
+AS_CASE([x$use_libbluray],
+ [xyes],[
+ INCLUDES="$INCLUDES $LIBBLURAY_CFLAGS";
+ if test "$host_vendor" != "apple"; then
+ XB_FIND_SONAME([BLURAY], [bluray], [use_libbluray])
+ fi;
+ AC_DEFINE([HAVE_LIBBLURAY], 1, [System has libbluray library])
+ AC_SUBST([HAVE_LIBBLURAY], 1)
+ ],[
+# AC_DEFINE([HAVE_LIBBLURAY], 0, [System has libbluray library])
+ AC_SUBST([HAVE_LIBBLURAY], 0)
+ ]
+)
+
# platform dependent libraries
if test "$host_vendor" = "apple" ; then
AC_CHECK_LIB([iconv], [main],, AC_MSG_ERROR($missing_library))
@@ -618,29 +670,6 @@ if [[ "$host_vendor" = "apple" ]]; then
HOST_NOT_APPLE=0
fi
-# check for library basenames
-AC_DEFUN([XB_FIND_SONAME],
-[
- AC_MSG_CHECKING([for lib$2 soname])
- $1_SONAME=$( $CC -print-file-name=lib$2.so | \
- while read output; do objdump -p $output | \
- grep "SONAME" | \
- sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
- if [[ -z "$$1_SONAME" ]]; then
- AC_MSG_RESULT([no])
- if test -z "$3" || test "x${$3}" = "xyes"; then
- AC_MSG_ERROR([Unable to determine soname of lib$2 library])
- else
- AC_MSG_WARN([Unable to determine soname of lib$2 library])
- $3=no
- AC_MSG_WARN([lib$2 support disabled])
- fi
- else
- AC_MSG_RESULT([$$1_SONAME])
- AC_SUBST($1_SONAME)
- fi
-])
-
if test "$host_vendor" != "apple"; then
XB_FIND_SONAME([CURL], [curl])
XB_FIND_SONAME([FLAC], [FLAC])
@@ -1157,6 +1186,12 @@ else
final_message="$final_message\n GOOM:\t\tNo"
fi
+if test "$use_libbluray" = "yes"; then
+ final_message="$final_message\n Bluray:\tYes"
+else
+ final_message="$final_message\n Bluray:\tNo"
+fi
+
if test "$use_mid" = "yes"; then
final_message="$final_message\n MID Support:\tYes"
SDL_DEFINES="$SDL_DEFINES -DMID"
@@ -1881,17 +1916,6 @@ if expr "X$host_cpu" : 'Xarm.*' > /dev/null; then :; else
fi
], [0])
-XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/libbdnav/], [
- if test "$host_vendor" = "apple" ; then
- ./configure --with-ssl-dir=/opt/local/include CFLAGS="$CFLAGS"
- else
- ./configure --without-openssl \
- --host=$host_alias \
- --build=$build_alias \
- --target=$target_alias CFLAGS="$CFLAGS"
- fi
-], [0])
-
XB_CONFIG_MODULE([xbmc/lib/libapetag], [
if test "$host_vendor" = "apple" ; then
CFLAGS="$CFLAGS -fno-common" \