aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChris "Koying" Browet <cbro@semperpax.com>2014-12-21 19:22:06 +0100
committerChris "koying" Browet <cbro@semperpax.com>2015-02-10 14:54:44 +0100
commitd3c46d246d932849ffb6641427b1278a9d4cd75b (patch)
treedf8f59db5b16c9907e74c1b85553f52b550c37ca /configure.in
parente82d519ffe45756114c6ef40af4f583986a268d6 (diff)
CHG: Move to c++11 and use std:shared_ptr rather than boost
Fixes the Nexus Player x86 crashes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 121f41c9a6..0f9cda7001 100644
--- a/configure.in
+++ b/configure.in
@@ -7,6 +7,7 @@ AC_CONFIG_HEADERS([xbmc/config.h])
AH_TOP([#pragma once])
m4_include([m4/ax_prog_cc_for_build.m4])
m4_include([m4/ax_prog_cxx_for_build.m4])
+m4_include([m4/ax_cxx_compile_stdcxx_11.m4])
m4_include([m4/ax_python_devel.m4])
m4_include([m4/xbmc_arch.m4])
@@ -579,6 +580,7 @@ PASSED_CXXFLAGS=$CXXFLAGS # Hack to override autoconf default values
AC_PROG_CXX
AX_PROG_CXX_FOR_BUILD
CXXFLAGS="$PASSED_CXXFLAGS $DEFAULT_COMPILE_FLAGS"
+AX_CXX_COMPILE_STDCXX_11(,[optional])
AC_PROG_LIBTOOL
AC_PROG_AWK
AC_PROG_LN_S
@@ -928,7 +930,7 @@ AC_CHECK_HEADER([sys/inotify.h], AC_DEFINE([HAVE_INOTIFY],[1],[Define if we have
# Checks for boost headers using CXX instead of CC
AC_LANG_PUSH([C++])
-AC_CHECK_HEADER([boost/shared_ptr.hpp],, AC_MSG_ERROR($missing_library))
+AC_CHECK_HEADER([boost/circular_buffer.hpp],, AC_MSG_ERROR($missing_library))
AC_LANG_POP([C++])
# Python