aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortopfs2 <topfs2@svn>2010-05-10 17:42:19 +0000
committertopfs2 <topfs2@svn>2010-05-10 17:42:19 +0000
commit4c26740eb03c0e80b7ad86132ca780b938b48b4e (patch)
treee02f3f32338e98a72ded8a5748abe80c2e7e4e49 /configure.in
parent6dd9069cc22181c8dd965026dd7dca9439a2361d (diff)
Applied #9200 - Thanks openelec.tv for the contribution!
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@29991 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 34 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index cffed6e38e..70f05a0eb9 100644
--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,9 @@ faac_not_found="== Could not find libfaac. FAAC support disabled. =="
faac_disabled="== FAAC support manually disabled. =="
dvdcss_enabled="== DVDCSS support enabled. =="
dvdcss_disabled="== DVDCSS support disabled. =="
+hal_not_found="== Could not find hal. HAL support disabled. =="
+halstorage_not_found="== Could not find hal-storage. HAL support disabled. =="
+hal_disabled="== HAL support disabled. =="
avahi_not_found="== Could not find libavahi-common or libavahi-client. Avahi support disabled. =="
avahi_disabled="== Avahi support disabled. =="
vdpau_not_found="== Could not find libvdpau. VDPAU support disabled. =="
@@ -198,6 +201,11 @@ AC_ARG_ENABLE([mid],
[enable MID support (default is no)])],
[use_mid=$enableval],
[use_mid=no])
+AC_ARG_ENABLE([hal],
+ [AS_HELP_STRING([--disable-hal],
+ [disable HAL support (default is enabled if hal and hal-storage is found)])],
+ [use_hal=$enableval],
+ [use_hal=yes])
AC_ARG_ENABLE([avahi],
[AS_HELP_STRING([--disable-avahi],
[disable Avahi support (default is enabled if libavahi-common and libavahi-client is found)])],
@@ -468,15 +476,9 @@ else
PKG_CHECK_MODULES([DBUS], [dbus-1],
[INCLUDES+=" $DBUS_CFLAGS"; LIBS+=" $DBUS_LIBS"],
AC_MSG_ERROR($missing_library))
- PKG_CHECK_MODULES([HAL_STORAGE], [hal-storage],
- [INCLUDES+=" $HAL_STORAGE_CFLAGS"; LIBS+=" $HAL_STORAGE_LIBS"],
- AC_MSG_ERROR($missing_library))
PKG_CHECK_MODULES([SDL], [sdl],
[INCLUDES+=" $SDL_CFLAGS"; LIBS+=" $SDL_LIBS"],
AC_MSG_ERROR($missing_library))
- PKG_CHECK_MODULES([HAL], [hal],
- [INCLUDES+=" $HAL_CFLAGS"; LIBS+=" $HAL_LIBS"],
- AC_MSG_ERROR($missing_library))
fi
# check for library basenames
@@ -534,6 +536,26 @@ else
fi
fi
+# HAL
+if test "$host_vendor" = "apple" ; then
+ use_hal="no"
+ AC_MSG_RESULT($hal_disabled)
+else
+ if test "$use_hal" = "yes"; then
+ PKG_CHECK_MODULES([HAL], [hal],
+ [INCLUDES+=" $HAL_CFLAGS"; LIBS+=" $HAL_LIBS"],
+ use_hal=no;AC_MSG_RESULT($hal_not_found))
+ PKG_CHECK_MODULES([HAL_STORAGE], [hal-storage],
+ [INCLUDES+=" $HAL_STORAGE_CFLAGS"; LIBS+=" $HAL_STORAGE_LIBS"],
+ use_hal=no;AC_MSG_RESULT($halstorage_not_found))
+ else
+ AC_MSG_RESULT($hal_disabled)
+ fi
+ if test "$use_hal" = "yes"; then
+ AC_DEFINE([HAS_HAL], [1], [Define to 1 if you have HAL installed])
+ fi
+fi
+
# avahi
if test "$host_vendor" = "apple" ; then
use_avahi="no"
@@ -982,6 +1004,12 @@ else
final_message="$final_message\n PulseAudio:\tNo"
fi
+if test "$use_hal" = "yes"; then
+ final_message="$final_message\n HAL Support:\tYes"
+else
+ final_message="$final_message\n HAL Support:\tNo"
+fi
+
if test "$use_faac" = "yes"; then
final_message="$final_message\n FAAC:\t\tYes"
else