aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSam Spilsbury <smspillaz@gmail.com>2013-07-25 13:59:25 +0800
committerSam Spilsbury <smspillaz@gmail.com>2013-10-12 00:34:37 +0800
commitdf4277989f28d172e9d1be4492b4f1c801d1dc4b (patch)
tree42aa74207f5fc640be2b94efa34e45bbd812d16f /configure.in
parent3c5e295bd2ac30ef039218db18521b1df8c050a0 (diff)
Listen for a new wl_keyboard from wl_seat_listener and create an
XKBKeymap implementing wayland::Keymap. This class keeps track of the keyboard state and MUST be updated every time a modifier or a key is pressed (eg, every time we get an event from the protocol). KeyboardProcessor implements the logic of converting XKB keysyms to XBMC keysyms. It also changes the focus state of the window and delivers key events to the XBMC event subsystem. TimeoutManager and WaylandEventLoop are just a simple abstraction for adding timeouts to the poll () / wl_display_dispatch () mainloop, in place so that we can implement key repeat
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4b09ddd1a4..99319d7e6d 100644
--- a/configure.in
+++ b/configure.in
@@ -979,10 +979,11 @@ if test "$use_wayland" = "yes" && test "$host_vendor" != "apple"; then
AC_MSG_ERROR($missing_library))
PKG_CHECK_MODULES([XKBCOMMON], [xkbcommon],
[INCLUDES="$INCLUDES $XKBCOMMON_CFLAGS";
- XKBCOMMON_LIBRARY_LINE=`LIBRARY=\`${PKG_CONFIG} --libs-only-l xkbcommon\`; echo ${LIBRARY:2}`
+ XKBCOMMON_LIBRARY_LINE=`LIBRARY=\`${PKG_CONFIG} --libs-only-l xkbcommon\`; echo ${LIBRARY:2}`;
XB_FIND_SONAME([XKBCOMMON_LIBRARY], $XKBCOMMON_LIBRARY_LINE)],
AC_MSG_ERROR($missing_library))
AC_DEFINE([HAVE_WAYLAND], [1], [Define to 1 if you have Wayland libs installed.])
+ AC_DEFINE([HAVE_XKBCOMMON], [1], [Define to 1 if you have libxkbcommon installed.])
# Disable SDL and X11 builds
use_sdl=no
@@ -2163,6 +2164,7 @@ fi
if test "$use_wayland" = "yes"; then
final_message="$final_message\n Wayland:\tYes"
USE_WAYLAND=1
+ USE_XKBCOMMON=1
else
final_message="$final_message\n Wayland:\tNo"
fi
@@ -2487,6 +2489,7 @@ OUTPUT_FILES="Makefile \
xbmc/music/karaoke/Makefile \
xbmc/osx/Makefile \
xbmc/guilib/Makefile \
+ xbmc/input/linux/Makefile \
xbmc/interfaces/Makefile \
xbmc/network/Makefile \
xbmc/network/upnp/Makefile \
@@ -2601,6 +2604,7 @@ AC_SUBST(USE_MYSQL)
AC_SUBST(USE_WAYLAND)
AC_SUBST(USE_WEB_SERVER)
AC_SUBST(USE_UPNP)
+AC_SUBST(USE_XKBCOMMON)
AC_SUBST(USE_OMXLIB)
AC_SUBST(USE_ANDROID)
AC_SUBST(GTEST_CONFIGURED)