aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSam Spilsbury <smspillaz@gmail.com>2013-08-17 10:33:48 +0800
committerSam Spilsbury <smspillaz@gmail.com>2013-10-12 00:34:39 +0800
commit0bcbf5881b34c38ec3df037f6b05bf6e1c3198b7 (patch)
treec7f65c8dc21c5688f785fa7b6091e86b9c6dfb4d /configure.in
parent7b2cc7eeee32a7a5e36c1896b8e2b867905a122a (diff)
Initial wayland test framework
Secondary Author: Cory Fields wayland: Fixup test building - Build tests in the test dir, not the main make. - Guard objects and code appropriately - Remove support for all but weston += 1.0.99. pkg-config and versioning were not implemented before that anyway.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 27 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 99319d7e6d..521bd3807a 100644
--- a/configure.in
+++ b/configure.in
@@ -985,12 +985,37 @@ if test "$use_wayland" = "yes" && test "$host_vendor" != "apple"; then
AC_DEFINE([HAVE_WAYLAND], [1], [Define to 1 if you have Wayland libs installed.])
AC_DEFINE([HAVE_XKBCOMMON], [1], [Define to 1 if you have libxkbcommon installed.])
+ # If we are also building with tests then we want to build
+ # wayland tests as well
+ if test "$configure_gtest" = "yes"; then
+ have_weston_sdk=no;
+ PKG_CHECK_MODULES([PIXMAN],
+ [pixman-1],have_pixman=yes,
+ [AC_MSG_WARN($missing_library); have_pixman=no])
+ PKG_CHECK_MODULES([WESTON],
+ [weston >= 1.1.90],[have_weston_sdk=yes],
+ [have_weston_sdk=no; AC_MSG_WARN($missing_library)])
+
+ AC_CHECK_PROG(WAYLAND_SCANNER, wayland-scanner, "wayland-scanner", "no")
+ if test "x$WAYLAND_SCANNER" == "xno"; then
+ AC_MSG_WARN($missing_program)
+ else
+ if test "x$have_weston_sdk" == "xyes" && test "x$have_pixman" = "xyes"; then
+ AC_SUBST(WAYLAND_TEST_INCLUDES,"$WAYLAND_CLIENT_CFLAGS $XKBCOMMON_CFLAGS $PIXMAN_CFLAGS $WESTON_CFLAGS")
+ AC_SUBST(WAYLAND_TEST_LIBS,"$WAYLAND_CLIENT_LIBS $XKBCOMMON_LIBS $PIXMAN_LIBS $WESTON_LIBS")
+ AC_DEFINE([HAVE_WESTON_SDK], [1], [Define to 1 if Weston SDK is installed.])
+ AC_SUBST(USE_WAYLAND_TEST_EXTENSION, 1)
+ fi
+ AC_SUBST(WAYLAND_SCANNER)
+ AC_DEFINE([HAVE_WAYLAND_XBMC_PROTO],[1],["Define to 1 if the wayland test-protocol will be built"])
+ fi
+ fi
+
# Disable SDL and X11 builds
use_sdl=no
use_joystick=no
use_x11=no
-
# Wayland requires the EGL "window system" which in turn only supports
# the OpenGL ES API, so enable gles support
use_gles=yes
@@ -2530,6 +2555,7 @@ OUTPUT_FILES="Makefile \
xbmc/android/jni/Makefile \
xbmc/utils/Makefile \
xbmc/main/Makefile \
+ xbmc/windowing/tests/wayland/Makefile \
project/cmake/xbmc-config.cmake"
if test "$use_skin_touched" = "yes"; then