aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarlson2k <k2k@narod.ru>2013-09-05 18:48:38 +0400
committerKarlson2k <k2k@narod.ru>2013-09-19 19:04:10 +0400
commit6745c80596a2b3acdf00d99b77eb7538cea7ab0b (patch)
tree012e7b62d70b7ecf20d769fa0d64112b66e09c7f /configure.in
parentf1c296932c0e6b2dfc147b705539c66d4059f1b6 (diff)
Configure: check for u16string/u32string declarations
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c85f2d8c9f..4127c9ddb0 100644
--- a/configure.in
+++ b/configure.in
@@ -916,6 +916,12 @@ if test "x$have_builtin_sync_val_compare_and_swap" = "xyes"; then
[Define to 1 if your compiler supports the __sync_val_compare_and_swap() intrinsic.])
fi
+# Check for u16string/u32string declarations
+AC_LANG_PUSH([C++])
+AC_CHECK_TYPES([std::u16string, std::u32string], [], [], [[#include <string>]])
+AC_CHECK_TYPES([char16_t, char32_t])
+AC_LANG_POP([C++])
+
# Add top source directory for all builds so we can use config.h
INCLUDES="-I\$(abs_top_srcdir) $INCLUDES"