aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCory Fields <theuni-nospam-@xbmc.org>2012-09-22 13:51:08 -0400
committerCory Fields <theuni-nospam-@xbmc.org>2012-09-22 14:10:37 -0400
commit23ee613f0012f15a838391711f6dc5ab6bbb6080 (patch)
tree2bf1a015ecc20e06f01d1405e19f52ac427e11f1 /configure.in
parent836f709294efa833096d9dec0f9dcb6309f3d6f4 (diff)
build: let ffmpeg figure out arm flags based on cpu
It uses use_cpu to test for the instruction-sets of each arch anyway, so setting it manually can only screw things up. Fixes busted dvdplayer playback on arm != rpi.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 7c32b73a47..b92dc4a3e4 100644
--- a/configure.in
+++ b/configure.in
@@ -668,10 +668,6 @@ case $use_platform in
use_texturepacker_native=yes
use_arch="arm"
use_cpu=arm1176jzf-s
- use_armv5te="yes"
- use_armv6t2="no"
- use_armv6="yes"
- use_armvfp="yes"
use_hardcoded_tables="yes"
use_alsa="no"
USE_TEXTUREPACKER_NATIVE_ROOT="$TEXTUREPACKER_NATIVE_ROOT"
@@ -2549,10 +2545,6 @@ XB_CONFIG_MODULE([lib/ffmpeg], [
`if test "$use_arch" != "no"; then echo --arch=$use_arch; fi`\
`if test "$use_cpu" != "no"; then echo --cpu=$use_cpu; fi`\
`if test "$use_neon" = "yes"; then echo --enable-neon; else echo --disable-neon; fi`\
- `if test "$use_armv5te" = "yes"; then echo --enable-armv5te; else echo --disable-armv5te; fi`\
- `if test "$use_armv6t2" = "yes"; then echo --enable-armv6t2; else echo --disable-armv6t2; fi`\
- `if test "$use_armv6" = "yes"; then echo --enable-armv6; else echo --disable-armv6; fi`\
- `if test "$use_armvfp" = "yes"; then echo --enable-armvfp; else echo --disable-armvfp; fi`\
--target-os=$ffmpeg_target_os \
--disable-muxers \
--enable-muxer=spdif \