aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorS. Davilla <davilla@4pi.com>2011-10-13 11:41:16 -0400
committerS. Davilla <davilla@4pi.com>2011-10-13 11:41:16 -0400
commit86683ca0c0ea6808022222b83897ee2b4fb35c55 (patch)
tree265361ea60447bba867d288975375c380fdbb535 /configure.in
parent27bf4b0fe09e440d0903bdb0f82173288e14ec47 (diff)
[osx/ios] fixed, now that we are using gnu sed, use proper sed params
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index e290828bbb..1fb7939335 100755
--- a/configure.in
+++ b/configure.in
@@ -2025,12 +2025,12 @@ XB_CONFIG_MODULE([lib/ffmpeg], [
--enable-pthreads \
--enable-runtime-cpudetect \
--cc="$CC" &&
- sed -i "" -e "s#YASM=yasm#YASM=${prefix}/bin/yasm#" config.mak &&
- sed -i "" -e "s#YASMDEP=yasm#YASMDEP=${prefix}/bin/yasm#" config.mak &&
- sed -i "" -e "s# -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 # #" config.mak
+ sed -ie "s#YASM=yasm#YASM=${prefix}/bin/yasm#" config.mak &&
+ sed -ie "s#YASMDEP=yasm#YASMDEP=${prefix}/bin/yasm#" config.mak &&
+ sed -ie "s# -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 # #" config.mak
if test "$use_arch" = "ppc"; then
- sed -i "" -e "s/HAVE_GNU_AS 1/HAVE_GNU_AS 0/" config.h
- sed -i "" -e "s/^HAVE_GNU_AS=yes/!HAVE_GNU_AS=yes/" config.mak
+ sed -ie "s/HAVE_GNU_AS 1/HAVE_GNU_AS 0/" config.h
+ sed -ie "s/^HAVE_GNU_AS=yes/!HAVE_GNU_AS=yes/" config.mak
fi
else
CFLAGS="" \
@@ -2146,9 +2146,9 @@ XB_CONFIG_MODULE([xbmc/visualizations/XBMCProjectM/libprojectM],[
-DSHARE_INSTALL_PREFIX:PATH="${datadir}" . &&
if test "$host_vendor" = "apple" ; then
# cmake has hardcoded paths to macports which bork our darwin depends cross/ppc, remove them
- sed -i "" -e "s|-L/opt/local/lib| |" CMakeFiles/projectM.dir/link.txt
- sed -i "" -e "s|-L/opt/local/lib| |" CMakeFiles/projectM.dir/flags.make
- sed -i "" -e "s|-I/opt/local/include| |" CMakeFiles/projectM.dir/flags.make
+ sed -ie "s|-L/opt/local/lib| |" CMakeFiles/projectM.dir/link.txt
+ sed -ie "s|-L/opt/local/lib| |" CMakeFiles/projectM.dir/flags.make
+ sed -ie "s|-I/opt/local/include| |" CMakeFiles/projectM.dir/flags.make
fi
set +x
], [$DISABLE_PROJECTM])