aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChris "koying" Browet <cbro@semperpax.com>2013-08-14 19:38:57 +0200
committerChris "Koying" Browet <cbro@semperpax.com>2014-02-17 15:00:32 +0100
commit6922aa8bf809ac59524ba0545c4a9476f428758d (patch)
tree5a3272e2502dec63dc6c0d8ee714a92bf7ecd1cd /configure.in
parent4af3b544366b93e3b0a5958a5504318611ae4d32 (diff)
FIX: implement libcurl openssl thread-safe locking
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 93d2772d54..42dd00e706 100644
--- a/configure.in
+++ b/configure.in
@@ -1106,6 +1106,11 @@ AC_CHECK_HEADER([FLAC/stream_decoder.h],, AC_MSG_ERROR($missing_library))
# we need to check for the header because if it exists we set the openssl
# and gcrypt MT callback hooks. This is mostly so that libcurl operates
# in MT manner correctly.
+AC_MSG_CHECKING([for CRYPTO_set_locking_callback(0)])
+AC_TRY_LINK([],[CRYPTO_set_locking_callback(0);],
+ [have_curl_static=yes],
+ [have_curl_static=no])
+AC_MSG_RESULT($have_curl_static)
AC_CHECK_HEADER([openssl/crypto.h], AC_DEFINE([HAVE_OPENSSL],[1],[Define if we have openssl]),)
AC_CHECK_HEADER([gcrypt.h], gcrypt_headers_available=yes,gcrypt_headers_available=no)
if test "$gcrypt_headers_available" = "yes"; then
@@ -1518,6 +1523,11 @@ else
AC_DEFINE([HAVE_LIBSSH], [1], [Whether to use libSSH library.])
fi
+# libcurl
+if test "x$have_curl_static" = "xyes"; then
+ AC_DEFINE([HAS_CURL_STATIC], [1], [Whether OpenSSL inside libcurl is static.])
+fi
+
# libRTMP
if test "$use_librtmp" != "no"; then
AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],,