aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortheuni <theuni-nospam-@xbmc.org>2012-06-05 00:16:48 -0400
committertheuni <theuni-nospam-@xbmc.org>2012-06-06 21:04:21 -0400
commitbc14f0cc09b6518f787e3e11d6ca78a7ab5c77cc (patch)
treece13f103f106198bcdebc4b776bac86fe0baba19 /configure.in
parent5f561f7d07099894fdf846b997b777ff73517313 (diff)
libxbmc: option for shared libxbmc.so
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bc1129204d..1149466a58 100755
--- a/configure.in
+++ b/configure.in
@@ -147,6 +147,11 @@ dashes="------------------------"
final_message="\n XBMC Configuration:"
final_message="\n$dashes$final_message\n$dashes"
+AC_ARG_ENABLE([shared-lib],
+ [AS_HELP_STRING([--enable-shared-lib],
+ [build libxbmc. helpful for tests (default is no)])],
+ [build_shared_lib=$enableval],
+ [build_shared_lib=no])
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug],
@@ -561,6 +566,11 @@ case $host in
esac
AC_SUBST([ARCH])
+if test "$build_shared_lib" = "yes"; then
+ final_message="$final_message\n Shared lib\tYes"
+ AC_SUBST(USE_LIBXBMC,1)
+fi
+
# platform debug flags
if test "$use_debug" = "yes"; then
final_message="$final_message\n Debugging:\tYes"