aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMemphiz <memphis@machzwo.de>2011-09-28 12:57:33 -0700
committerMemphiz <memphis@machzwo.de>2011-09-28 12:57:33 -0700
commitb2b52143f06955edbf3dd461755fb28667ce5065 (patch)
tree9738733e2433e443364724f0ee78529da2075c99 /configure.in
parent5b3f013938029637c3c740acbc956940af381309 (diff)
parentff859829ebb4a7a266a480d94a9b2da84c9f21bd (diff)
Merge pull request #447 from Memphiz/airtunes
Airtunes support for ios/osx/linux
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 856217df66..cd86d2bf95 100755
--- a/configure.in
+++ b/configure.in
@@ -111,6 +111,8 @@ libnfs_not_found="== Could not find libnfs. NFS support disabled. =="
libnfs_disabled="== NFS support disabled. =="
libafpclient_not_found="== Could not find libafpclient. AFP support disabled. =="
libafpclient_disabled="== AFP support disabled. =="
+libshairport_not_found="== Could not find libshairport. AirTunes support disabled. =="
+libshairport_disabled="== AirTunes support disabled. =="
samba_disabled="== SAMBA support disabled. =="
libplist_not_found="== Could not find libplist. AirPlay support disabled. =="
libplist_disabled="== AirPlay support disabled. =="
@@ -297,6 +299,12 @@ AC_ARG_ENABLE([airplay],
[use_airplay=$enableval],
[use_airplay=auto])
+AC_ARG_ENABLE([airtunes],
+ [AS_HELP_STRING([--enable-airtunes],
+ [enable AirTunes support(default is auto)])],
+ [use_airtunes=$enableval],
+ [use_airtunes=auto])
+
AC_ARG_ENABLE([ffmpeg_libvorbis],
[AS_HELP_STRING([--enable-ffmpeg-libvorbis],
[enable FFmpeg vorbis encoding (default is no)])],
@@ -1028,6 +1036,23 @@ if test "$use_airplay" != "no"; then
fi
fi
+# libshairport for AirTunes
+USE_AIRTUNES=0
+if test "x$use_airtunes" != "xno"; then
+ AC_CHECK_LIB([shairport], [shairport_set_ao],,
+ [if test "x$use_airtunes" = "xyes"; then
+ AC_MSG_ERROR($libshairport_not_found)
+ elif test "x$use_airtunes" != "xno"; then
+ AC_MSG_NOTICE($libshairport_not_found)
+ use_airtunes="no"
+ fi
+ ])
+
+ if test "x$use_airtunes" != "xno"; then
+ XB_FIND_SONAME([SHAIRPORT], [shairport], [use_airtunes])
+ USE_AIRTUNES=1
+ fi
+fi
### External libraries checks
# External FFmpeg
@@ -1632,6 +1657,12 @@ else
final_message="$final_message\n AirPLay support:\tNo"
fi
+if test "x$use_airtunes" != "xno"; then
+ final_message="$final_message\n AirTunes support:\tYes"
+else
+ final_message="$final_message\n AirTunes support:\tNo"
+fi
+
if test "$use_optical_drive" = "yes"; then
final_message="$final_message\n Optical drive:\tYes"
else
@@ -1753,6 +1784,7 @@ AC_SUBST(USE_ALSA)
AC_SUBST(USE_TEXTUREPACKER)
AC_SUBST(USE_TEXTUREPACKER_NATIVE)
AC_SUBST(USE_TEXTUREPACKER_NATIVE_ROOT)
+AC_SUBST(USE_AIRTUNES)
# pushd and popd are not available in other shells besides bash, so implement
# our own pushd/popd functions