aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndres Mejia <mcitadel@gmail.com>2011-07-16 23:33:12 -0400
committerAndres Mejia <mcitadel@gmail.com>2011-07-16 23:33:12 -0400
commita6c21d8bb65284791d33da240ca15aa0fdd851ae (patch)
treee7c951b94afb72af93036466066157d6129cb16c /configure.in
parent61b782d6da476870abd4cd979f35909a24479cc3 (diff)
Only enable openmax if gles is enabled.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index eb70650549..6788e18106 100644
--- a/configure.in
+++ b/configure.in
@@ -173,7 +173,7 @@ AC_ARG_ENABLE([vtbdecoder],
AC_ARG_ENABLE([openmax],
[AS_HELP_STRING([--enable-openmax],
- [enable OpenMax decoding (default is auto)])],
+ [enable OpenMax decoding (default is auto, requires OpenGLES)])],
[use_openmax=$enableval],
[use_openmax=auto])
@@ -1066,16 +1066,17 @@ if test "$host_vendor" = "apple" ; then
USE_OPENMAX=0
AC_MSG_NOTICE($openmax_disabled)
else
- if test "$use_openmax" = "auto"; then
+ if test "$use_gles" = "yes" && test "$use_openmax" = "auto"; then
PKG_CHECK_MODULES([OPENMAX], [libomxil-bellagio],
USE_OPENMAX=1;[INCLUDES="$INCLUDES $OPENMAX_CFLAGS"; LIBS="$LIBS $OPENMAX_LIBS"],
use_openmax=no;USE_OPENMAX=0;AC_MSG_RESULT($openmax_not_found))
- elif test "$use_openmax" = "yes"; then
+ elif test "$use_gles" = "yes" && test "$use_openmax" = "yes"; then
PKG_CHECK_MODULES([OPENMAX], [libomxil-bellagio],
USE_OPENMAX=1;[INCLUDES="$INCLUDES $OPENMAX_CFLAGS"; LIBS="$LIBS $OPENMAX_LIBS"],
AC_MSG_ERROR($openmax_not_found))
else
AC_MSG_NOTICE($openmax_disabled)
+ use_openmax=no
USE_OPENMAX=0
fi
fi