aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoralthekiller <althekiller@svn>2010-07-17 04:45:36 +0000
committeralthekiller <althekiller@svn>2010-07-17 04:45:36 +0000
commit9beff93efb635543954db59bd21752bbe64da524 (patch)
tree2c8122137baad37c571eb2fcb2c475720a45b372 /configure.in
parent001604da0ac96b0907fd5c84cda5f31facb35243 (diff)
Changed: xb_find_soname macro shouldn't error on optional features, disable them instead.
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@31884 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9f29f60039..99192c70e7 100644
--- a/configure.in
+++ b/configure.in
@@ -585,7 +585,13 @@ AC_DEFUN([XB_FIND_SONAME],
sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
if [[ -z "$$1_SONAME" ]]; then
AC_MSG_RESULT([no])
- AC_MSG_ERROR([Unable to determine soname of lib$2 library])
+ if test -z "$3" || test "x${$3}" = "xyes"; then
+ AC_MSG_ERROR([Unable to determine soname of lib$2 library])
+ else
+ AC_MSG_WARN([Unable to determine soname of lib$2 library])
+ $3=no
+ AC_MSG_WARN([lib$2 support disabled])
+ fi
else
AC_MSG_RESULT([$$1_SONAME])
AC_SUBST($1_SONAME)