aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorelupus <elupus@svn>2010-07-16 19:11:04 +0000
committerelupus <elupus@svn>2010-07-16 19:11:04 +0000
commit81b223d33c7d7a566e34a306288c52364aa4d984 (patch)
tree5f0aedf8dd299ee45ad14b244e313cb0fd4733a9 /configure.in
parent1cebedc1ce0dc3c07bd548f64c5d0e8e14fde92a (diff)
changed: don't pass along our junk CFLAGS to ffmpeg build, only pass anything user may have specified
changed: enable pic using ffmpeg configure option for the arches that need it git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@31853 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0f575dcdf0..9f29f60039 100644
--- a/configure.in
+++ b/configure.in
@@ -1562,7 +1562,7 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/ffmpeg], [
else
./configure \
- --extra-cflags="$CFLAGS $FFMPEG_EXTRACFLAGS" \
+ --extra-cflags="$PASSED_CFLAGS $FFMPEG_EXTRACFLAGS" \
--disable-static \
`if test "$use_debug" = "no"; then echo --disable-debug; fi` \
`if test "$cross_compiling" = "yes"; then echo --enable-cross-compile; fi` \
@@ -1589,7 +1589,7 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/ffmpeg], [
--enable-libfaad \
--enable-protocol=http \
--enable-pthreads \
- `case $host_cpu in powerpc*|arm*) echo --enable-pic ;; esac` \
+ `case $host_cpu in powerpc*|arm*|amd64*|x86_64*|ia64*) echo --enable-pic ;; esac` \
--cc="$CC" &&
sed -i -e "s#define HAVE_SYMVER 1#define HAVE_SYMVER 0#" config.h &&
sed -i -e "s#define HAVE_SYMVER_GNU_ASM 1#define HAVE_SYMVER_GNU_ASM 0#" config.h