aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortheuni <theuni-nospam-@xbmc.org>2011-09-21 01:53:37 -0400
committertheuni <theuni-nospam-@xbmc.org>2011-09-21 01:53:37 -0400
commit605749214a8ace26b0a37dfb684ab295822f8440 (patch)
tree86d9c88895f4afbab88a5134b22b8e825ae6bc3a /configure.in
parente63c0266f17ed6232f4e4503cf5f0e5ee79b442d (diff)
build: quit creating a.out
redirect gcc to /dev/null to avoid writing to a file
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7c2149f026..763b7ee42f 100755
--- a/configure.in
+++ b/configure.in
@@ -20,7 +20,7 @@ AC_DEFUN([XB_FIND_SONAME],
[
if [[ "$host_vendor" != "apple" ]]; then
AC_MSG_CHECKING([for lib$2 soname])
- $1_FILENAME=$($CC -nostdlib $LDFLAGS -l$2 -Wl,-M 2>/dev/null | grep "^LOAD.*$2" | awk '{V=2; print $V}')
+ $1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-M 2>/dev/null | grep "^LOAD.*$2" | awk '{V=2; print $V}')
if [[ ! -z $$1_FILENAME ]]; then
$1_SONAME=$(objdump -p $$1_FILENAME | grep "SONAME.*$2" | awk '{V=2; print $V}')
fi