aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortheuni <theuni-nospam-@xbmc.org>2011-03-05 23:52:13 -0500
committertheuni <theuni-nospam-@xbmc.org>2011-03-20 20:35:25 -0400
commit45b7cd6b054c4f73bd4c35261bb2b395db7980a6 (patch)
tree114ec60b26258ea6ad35bb23ce584312821e0e45 /configure.in
parent8f0ce47d889ecb7a5293f1c46ac96953166d164c (diff)
changed: prepend version string with "date-"
This is the date of the last revision and _not_ the compile date. Should help with sorting as well as eyeballing versions. In addition, the Windows binary has been renamed from XBMCSetup-Rev_[revision] to XBMCSetup-[date-revision]. Thanks to CrystalP and jcarroll for the Windows help.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 40708f3c4a..dafc7042d2 100644
--- a/configure.in
+++ b/configure.in
@@ -1281,7 +1281,7 @@ else
fi
if test "$HAVE_GIT" = "yes"; then
- GIT_REV=$(git rev-parse --short HEAD)
+ GIT_REV=$(git --no-pager log --abbrev=7 -1 --pretty=format:"%h %ci" HEAD | awk '{gsub("-", "");print $2"-"$1}')
fi
if test "$GIT_REV" = ""; then
GIT_REV="Unknown"