aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortheuni <theuni-nospam-@xbmc.org>2012-05-26 11:40:58 -0400
committerCory Fields <theuni-nospam-@xbmc.org>2012-08-08 18:47:59 -0400
commit4088cf014bb4686cccd68f7ac173c49cf5b4a557 (patch)
tree289d3f21acd492db21df840d053a36ca872952e1 /configure.in
parent557e83ffaf60e923e4a32d0cbf58540a7d29fbe4 (diff)
[droid] add fallback for soname detection for gold linker
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d3ad810365..3f709f47b1 100755
--- a/configure.in
+++ b/configure.in
@@ -27,8 +27,12 @@ AC_DEFUN([XB_FIND_SONAME],
elif [[ "$host_vendor" != "apple" ]]; then
AC_MSG_CHECKING([for lib$2 soname])
$1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-M 2>/dev/null | grep "^LOAD.*$2" | awk '{V=2; print $V}')
+ if [[ -z $$1_FILENAME ]]; then
+ #try gold linker syntax
+ $1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-t 3>&1 1>&2 2>&3 | grep "$2")
+ fi
if [[ ! -z $$1_FILENAME ]]; then
- $1_SONAME=$(objdump -p $$1_FILENAME | grep "SONAME.*$2" | awk '{V=2; print $V}')
+ $1_SONAME=$($OBJDUMP -p $$1_FILENAME | grep "SONAME.*$2" | awk '{V=2; print $V}')
fi
else
AC_MSG_CHECKING([for lib$2 dylib])