aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@svn>2010-08-07 03:22:37 +0000
committerdavilla <davilla@svn>2010-08-07 03:22:37 +0000
commit3eb34c3c0773fa28f2b5d016ad6d12613e0e2339 (patch)
tree2de00a91dfa286152217670b9818e696a413b6eb /configure.in
parentbd9693345b1788de2ff0c2e5a5d977c2be06629e (diff)
changed, dyload libbluray instead of static linking it
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@32561 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 26 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index cd3ebc790e..58d78d54c1 100644
--- a/configure.in
+++ b/configure.in
@@ -14,6 +14,29 @@ tolower(){
echo "$@" | tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz
}
+# check for library basenames
+AC_DEFUN([XB_FIND_SONAME],
+[
+ AC_MSG_CHECKING([for lib$2 soname])
+ $1_SONAME=$( $CC -print-file-name=lib$2.so | \
+ while read output; do objdump -p $output | \
+ grep "SONAME" | \
+ sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
+ if [[ -z "$$1_SONAME" ]]; then
+ AC_MSG_RESULT([no])
+ if test -z "$3" || test "x${$3}" = "xyes"; then
+ AC_MSG_ERROR([Unable to determine soname of lib$2 library])
+ else
+ AC_MSG_WARN([Unable to determine soname of lib$2 library])
+ $3=no
+ AC_MSG_WARN([lib$2 support disabled])
+ fi
+ else
+ AC_MSG_RESULT([$$1_SONAME])
+ AC_SUBST($1_SONAME)
+ fi
+])
+
# General message strings
configure_debug="ERROR: this is a configure debug statement"
missing_library="Could not find a required library. Please see the README for your platform."
@@ -567,7 +590,9 @@ AS_CASE([x$use_libbluray],
AS_CASE([x$use_libbluray],
[xyes],[
INCLUDES="$INCLUDES $LIBBLURAY_CFLAGS";
- LIBS="$LIBS $LIBBLURAY_LIBS";
+ if test "$host_vendor" != "apple"; then
+ XB_FIND_SONAME([BLURAY], [bluray], [use_libbluray])
+ fi;
AC_DEFINE([HAVE_LIBBLURAY], 1, [System has libbluray library])
AC_SUBST([HAVE_LIBBLURAY], 1)
],[
@@ -645,29 +670,6 @@ if [[ "$host_vendor" = "apple" ]]; then
HOST_NOT_APPLE=0
fi
-# check for library basenames
-AC_DEFUN([XB_FIND_SONAME],
-[
- AC_MSG_CHECKING([for lib$2 soname])
- $1_SONAME=$( $CC -print-file-name=lib$2.so | \
- while read output; do objdump -p $output | \
- grep "SONAME" | \
- sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
- if [[ -z "$$1_SONAME" ]]; then
- AC_MSG_RESULT([no])
- if test -z "$3" || test "x${$3}" = "xyes"; then
- AC_MSG_ERROR([Unable to determine soname of lib$2 library])
- else
- AC_MSG_WARN([Unable to determine soname of lib$2 library])
- $3=no
- AC_MSG_WARN([lib$2 support disabled])
- fi
- else
- AC_MSG_RESULT([$$1_SONAME])
- AC_SUBST($1_SONAME)
- fi
-])
-
if test "$host_vendor" != "apple"; then
XB_FIND_SONAME([CURL], [curl])
XB_FIND_SONAME([FLAC], [FLAC])