aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorS. Davilla <davilla@4pi.com>2012-06-29 11:21:18 -0400
committerS. Davilla <davilla@4pi.com>2012-06-29 12:02:23 -0400
commit26b6e0a719e017d5efc22474e78a645efb6e02c8 (patch)
tree296d11336878fc1ac469dd3b82de20deb3449fd2 /configure.in
parent0a8945a63fb1ad07e952961f1090b6948a9f8b19 (diff)
[osx] fixed make from command-line
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in31
1 files changed, 21 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index d5ccdae515..6a6792f543 100755
--- a/configure.in
+++ b/configure.in
@@ -616,22 +616,20 @@ if test "$host_vendor" = "apple" ; then
# standard xbmc paths
INCLUDES="$INCLUDES -I\$(abs_top_srcdir)/xbmc/osx"
if test "$use_arch" != "arm"; then
- LIBS="$LIBS -framework IOKit"
+ LIBS="$LIBS -framework ApplicationServices"
+ LIBS="$LIBS -framework AudioUnit"
+ LIBS="$LIBS -framework AudioToolbox"
LIBS="$LIBS -framework Cocoa"
- LIBS="$LIBS -framework AppKit"
- LIBS="$LIBS -framework Carbon"
LIBS="$LIBS -framework CoreAudio"
- LIBS="$LIBS -framework QuickTime"
- LIBS="$LIBS -framework AudioUnit"
- LIBS="$LIBS -framework Foundation"
- LIBS="$LIBS -framework CoreServices"
LIBS="$LIBS -framework CoreVideo"
- LIBS="$LIBS -framework CoreAudio"
- LIBS="$LIBS -framework AudioToolbox"
+ LIBS="$LIBS -framework CoreServices"
LIBS="$LIBS -framework CoreFoundation"
LIBS="$LIBS -framework DiskArbitration"
- LIBS="$LIBS -framework ApplicationServices"
+ LIBS="$LIBS -framework IOKit"
+ LIBS="$LIBS -framework IOSurface"
+ LIBS="$LIBS -framework QuartzCore"
fi
+ USE_EXTERNAL_FFMPEG=1
elif test "$use_arch" = "arm"; then
CFLAGS="$CFLAGS -mno-apcs-stack-check"
CXXFLAGS="$CXXFLAGS -mno-apcs-stack-check"
@@ -1974,6 +1972,19 @@ else
final_message="$final_message\n External FFmpeg:\tNo"
fi
+if test "$host_vendor" = "apple" ; then
+ # built internal but referenced as external, we link directly to them.
+ # this MUST be the last thing before OUTPUT_FILES as they do not
+ # exist until after we build FFMpeg.
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libavcodec -lavcodec"
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libavfilter -lavfilter"
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libswresample -lswresample"
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libavformat -lavformat"
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libavutil -lavutil"
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libpostproc -lpostproc"
+ LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libswscale -lswscale"
+fi
+
OUTPUT_FILES="Makefile \
Makefile.include \
addons/skin.confluence/media/Makefile \