aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMemphiz <memphis@machzwo.de>2012-06-26 20:26:04 +0200
committerCory Fields <theuni-nospam-@xbmc.org>2012-08-08 19:14:48 -0400
commit1fda24fb20a7a152e5c60611b0c839bfe639cd76 (patch)
treeb4f990300ded596c39c597c969753dc2c7a8bbeb /configure.in
parente03918901da160d62aa22d87b568007b13d6746d (diff)
[droid] - last puzzle for making crosscompilation on darwin possible (gather the default built arch from libsdl_image in native deps and use this for building libsquish-native.so and TexturePacker)
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8ad816e2be..7297bf8c9d 100755
--- a/configure.in
+++ b/configure.in
@@ -591,6 +591,15 @@ case $host in
esac
AC_SUBST([ARCH])
+
+check_sdl_arch=[`file $USE_TEXTUREPACKER_NATIVE_ROOT/lib/libSDL_image.dylib | awk '{print $NF}'`]
+if test "x$check_sdl_arch" = "xi386" ; then
+ DARWIN_NATIVE_ARCH=-m32
+elif test "x$check_sdl_arch" = "xx86_64" ; then
+ DARWIN_NATIVE_ARCH=-m64
+fi
+AC_SUBST([DARWIN_NATIVE_ARCH])
+
if test "$target_platform" = "target_android" ; then
USE_ANDROID=1
use_texturepacker_native=yes