aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoranssih <anssih@svn>2010-07-20 14:43:47 +0000
committeranssih <anssih@svn>2010-07-20 14:43:47 +0000
commitd937d6b660e123efebb7d24dc205165f4b48acbd (patch)
tree4dd5e5ac77eb0198caf8e51c08bef82ae9fed7f0 /configure.in
parentaf1bca8e5d254b957c2ad726a9152fecdd00342e (diff)
added: configure option for rtmp support
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@32006 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 24 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 0d5cb991da..644ab6f623 100644
--- a/configure.in
+++ b/configure.in
@@ -46,7 +46,8 @@ openmax_disabled="== OpenMax support manually disabled. =="
openmax_not_found="== Could not find libnvomx. OpenMax support disabled. =="
libass_using_internal="== External Libass not found, using internal. =="
ssh_not_found="== Could not find libssh. SSH FTP VFS support disabled. =="
-librtmp_not_found="== Could not find libRTMP. libRTMP support disabled. =="
+librtmp_not_found="== Could not find libRTMP. RTMP support disabled. =="
+librtmp_disabled="== RTMP support disabled. =="
# External library message strings
external_libraries_enabled="== Use of all supported external libraries enabled. =="
@@ -173,6 +174,12 @@ AC_ARG_ENABLE([pulse],
[use_pulse=$enableval],
[use_pulse=auto])
+AC_ARG_ENABLE([rtmp],
+ [AS_HELP_STRING([--enable-rtmp],
+ [enable RTMP support via librtmp (default is auto)])],
+ [use_librtmp=$enableval],
+ [use_librtmp=auto])
+
AC_ARG_ENABLE([ffmpeg_libvorbis],
[AS_HELP_STRING([--enable-ffmpeg-libvorbis],
[enable FFmpeg vorbis encoding (default is no)])],
@@ -722,8 +729,21 @@ else
fi
# libRTMP
-AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],use_librtmp=yes,
-use_librtmp=no;AC_MSG_RESULT($librtmp_not_found))
+if test "$use_librtmp" != "no"; then
+ AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],,
+ [if test "$use_librtmp" = "yes"; then
+ AC_MSG_ERROR($librtmp_not_found)
+ elif test "$use_librtmp" != "no"; then
+ AC_MSG_NOTICE($librtmp_not_found)
+ use_librtmp="no"
+ fi
+ ])
+ if test "$use_librtmp" != "no"; then
+ AC_DEFINE([HAS_LIBRTMP], [1], [Whether to use libRTMP library.])
+ fi
+else
+ AC_MSG_NOTICE($librtmp_disabled)
+fi
### External libraries checks
# External FFmpeg
@@ -782,10 +802,6 @@ else
AC_DEFINE([PIX_FMT_VDPAU_MPEG4_IN_AVUTIL], [1], [Whether AVUtil defines PIX_FMT_VDPAU_MPEG4.])
fi
-if test "$use_librtmp" = "yes"; then
- AC_DEFINE([HAS_LIBRTMP], [1], [Whether to use libRTMP library.])
-fi
-
# External liba52 if deprecated a52 support is enabled
if test "$use_liba52" = "yes" && "$use_external_liba52" = "yes"; then
AC_CHECK_LIB([a52], [main],, AC_MSG_ERROR($missing_library))
@@ -1253,7 +1269,7 @@ else
final_message="$final_message\n Webserver:\tNo"
fi
-if test "$use_librtmp" = "yes"; then
+if test "$use_librtmp" != "no"; then
final_message="$final_message\n libRTMP support:\tYes"
else
final_message="$final_message\n libRTMP support:\tNo"