aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorVladlen Y. Koshelev <vlad.kosh@gmail.com>2014-02-03 13:23:59 +0400
committerVladlen Y. Koshelev <vlad.kosh@gmail.com>2014-02-03 13:23:59 +0400
commit2449e6e6cf3ce3acfed2c084aae4ed1ce768aa1a (patch)
treeb6586628654bebd1e4ff2aa07acafc119b55b825 /configure.in
parentb6d31a3f32ea69f948ff4d020741ee1b986b1544 (diff)
[configure] get git revision from xbmc git root
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2056ee11bd..ef59b9306d 100644
--- a/configure.in
+++ b/configure.in
@@ -759,7 +759,7 @@ AC_CHECK_PROG(HAVE_GIT,git,"yes","no",)
if test "$GIT_REV" = ""; then
if test -f VERSION ; then
GIT_REV=$(awk 'END{print substr($1,1,16)}' VERSION)
- elif test "$HAVE_GIT" = "yes"; then
+ elif test "$HAVE_GIT" = "yes" -a -d $(abs_top_srcdir)/.git; then
GIT_REV=$(git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h %ci" HEAD | awk '{gsub("-", "");print $2"-"$1}')
else
GIT_REV="Unknown"