aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMemphiz <memphis@machzwo.de>2014-01-15 19:32:58 +0100
committerMemphiz <memphis@machzwo.de>2014-01-15 20:50:37 +0100
commit0e53fea3bbf092cccad9f5ade492754ee2a22ead (patch)
tree278436c4168dda22ef9ab4885962abb0326efb61 /configure.in
parenta3bb33ddb34f2ac4101d272997fcf7f626cc17f3 (diff)
[ios7/ios/atv2] - link statically against libmpeg2 - since ios7 we crash and burn when we load libmpeg2 as dylib - closes #14813
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7231ff80c9..73923e7908 100644
--- a/configure.in
+++ b/configure.in
@@ -1250,7 +1250,12 @@ XB_FIND_SONAME([VORBIS], [vorbis])
XB_FIND_SONAME([VORBISFILE], [vorbisfile])
XB_FIND_SONAME([MODPLUG], [modplug])
XB_FIND_SONAME([ASS], [ass])
-XB_FIND_SONAME([MPEG2], [mpeg2])
+
+#link statically against mpeg2 on ios because of ios7
+#crash & burn if dyloaded
+if test "$ARCH" != "arm-osx" ; then
+ XB_FIND_SONAME([MPEG2], [mpeg2])
+fi
# Audio encoders
if test "x$use_libmp3lame" != "xno"; then