aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-14 11:36:26 -0400
committerAlexis Ballier <aballier@gentoo.org>2012-08-14 11:36:26 -0400
commitf00b0c2352e0477238706263746d63e328dfd3ed (patch)
tree91129218f82512b13ee519940424514634a34be6 /configure.in
parent563ad420f9ff2683779a522d2449322f06ecfdde (diff)
Configure: require either libswresample or libavresample. Prefer libswresample.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2db2d70252..401067de7c 100644
--- a/configure.in
+++ b/configure.in
@@ -1412,6 +1412,13 @@ if test "$use_external_ffmpeg" = "yes"; then
# libavcore is optional
PKG_CHECK_EXISTS([libavcore], FFMPEG_LIBNAMES="$FFMPEG_LIBNAMES libavcore")
+ # one of libswresample or libavresample is needed
+ PKG_CHECK_EXISTS([libswresample], FFMPEG_LIBNAMES="$FFMPEG_LIBNAMES libswresample",
+ [PKG_CHECK_EXISTS([libavresample],
+ FFMPEG_LIBNAMES="$FFMPEG_LIBNAMES libavresample",
+ AC_MSG_ERROR([You need either libswresample
+ or libavresample.]))])
+
PKG_CHECK_MODULES([FFMPEG], [$FFMPEG_LIBNAMES],
[INCLUDES="$INCLUDES $FFMPEG_CFLAGS"; LIBS="$LIBS $FFMPEG_LIBS"],
AC_MSG_ERROR($missing_library))
@@ -1445,6 +1452,9 @@ if test "$use_external_ffmpeg" = "yes"; then
AC_CHECK_HEADERS([libswscale/rgb2rgb.h],,)
AC_CHECK_HEADERS([ffmpeg/rgb2rgb.h],,)
+ # Check for libswresample or libavresample headers.
+ AC_CHECK_HEADERS([libswresample/swresample.h libavresample/avresample.h])
+
# Check if AVFilterBufferRefVideoProps AVRational member is named
# 'pixel_aspect' or 'sample_aspect_ratio'.
AC_CHECK_MEMBER([AVFilterBufferRefVideoProps.sample_aspect_ratio],