aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2014-02-13 16:52:41 +0100
committerwsnipex <wsnipex@a1.net>2014-02-13 17:40:33 +0100
commitf5758d6a3b887d2d1d93c787337eaddaea5cc15f (patch)
tree23e0995a8901160943240816011e6d1440e6264b /configure.in
parenta74973f731cacf8262c6bc3cca4b811290e221ae (diff)
[configure] make sure abs_top_srcdir is always defined
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8ebe6f0110..93d2772d54 100644
--- a/configure.in
+++ b/configure.in
@@ -18,6 +18,9 @@ tolower(){
echo "$@" | tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz
}
+# workaround for autotools that don't set this
+abs_top_srcdir=${abs_top_srcdir=$(cd $srcdir; pwd)}
+
# check for enabling additional players
AC_DEFUN([XB_ADD_PLAYER],
[
@@ -757,7 +760,7 @@ AC_CHECK_PROG(HAVE_GIT,git,"yes","no",)
if test "$GIT_REV" = ""; then
if test -f VERSION ; then
GIT_REV=$(awk 'END{print substr($1,1,16)}' VERSION)
- elif test "$HAVE_GIT" = "yes" -a -d $(abs_top_srcdir)/.git; then
+ elif test "$HAVE_GIT" = "yes" -a -d ${abs_top_srcdir}/.git; then
GIT_REV=$(git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h %ci" HEAD | awk '{gsub("-", "");print $2"-"$1}')
else
GIT_REV="Unknown"