aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2013-07-04 20:30:07 +0200
committerwsnipex <wsnipex@a1.net>2013-07-04 20:30:07 +0200
commiteba711e08f82c1579a37db8ab4e79d431a99f9e7 (patch)
tree65efa7b4ab99bb46d87fee87737f97f62233966d /configure.in
parent9dfe7cbef07864dcd918000b4a7703640fbed429 (diff)
[configure] fix goldlinker check
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 46ec31f578..01ddfdb820 100644
--- a/configure.in
+++ b/configure.in
@@ -59,7 +59,7 @@ AC_DEFUN([XB_FIND_SONAME],
$1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-M 2>/dev/null | grep "^LOAD.*$2" | awk '{V=2; print $V}')
if [[ -z $$1_FILENAME ]]; then
#try gold linker syntax
- $1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-t 3>&1 1>&2 2>&3 | grep "$2")
+ $1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-t 3>&1 1>&2 2>&3 | grep "lib$2")
fi
if [[ ! -z $$1_FILENAME ]]; then
$1_SONAME=$($OBJDUMP -p $$1_FILENAME | grep "SONAME.*$2" | awk '{V=2; print $V}')