aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@svn>2010-06-17 17:38:51 +0000
committerdavilla <davilla@svn>2010-06-17 17:38:51 +0000
commit6981106e665835371f19edf54564df10afe48eb9 (patch)
tree1b11ba671d82d47916ca438c675c691df2224484 /configure.in
parentd7daa3d8114344d9f665b3a7309f13a0521e9550 (diff)
changed. switch from internal to system librtmp
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@31149 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 56ee729904..52df195103 100644
--- a/configure.in
+++ b/configure.in
@@ -47,6 +47,7 @@ openmax_not_found="== Could not find libnvomx. OpenMax support disabled. =="
libass_using_internal="== External Libass not found, using internal. =="
ssh_not_found="== Could not find libssh. SSH FTP VFS support disabled. =="
libvpx_not_found="== Could not find libvpx. WebM support disabled. =="
+librtmp_not_found="== Could not find libRTMP. libRTMP support disabled. =="
# External library message strings
external_libraries_enabled="== Use of all supported external libraries enabled. =="
@@ -719,6 +720,10 @@ fi
AC_CHECK_LIB([vpx], [main],use_vpx=yes,
use_vpx=no;AC_MSG_RESULT($vpx_not_found))
+# libRTMP
+AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],use_librtmp=yes,
+use_librtmp=no;AC_MSG_RESULT($librtmp_not_found))
+
### External libraries checks
# External FFmpeg
if test "$use_external_ffmpeg" = "yes"; then
@@ -779,6 +784,10 @@ else
USE_VPX=0
fi
+if test "$use_librtmp" = "yes"; then
+ AC_DEFINE([HAS_LIBRTMP], [1], [Whether to use libRTMP library.])
+fi
+
# External liba52 if deprecated a52 support is enabled
if test "$use_liba52" = "yes" && "$use_external_liba52" = "yes"; then
AC_CHECK_LIB([a52], [main],, AC_MSG_ERROR($missing_library))
@@ -1237,6 +1246,12 @@ else
final_message="$final_message\n WebM support:\tNo"
fi
+if test "$use_librtmp" = "yes"; then
+ final_message="$final_message\n libRTMP support:\tYes"
+else
+ final_message="$final_message\n libRTMP support:\tNo"
+fi
+
if test "$use_libdts" = "yes"; then
USE_LIBDTS_DECODER=1
AC_DEFINE([USE_LIBDTS_DECODER], [1], [Define to 1 to enable deprecated libdts support])