aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCory Fields <theuni-nospam-@xbmc.org>2012-06-16 11:51:48 -0400
committerCory Fields <theuni-nospam-@xbmc.org>2012-08-08 18:59:24 -0400
commit3af883073d8f124e43d5e6cc3213d825306aa3b8 (patch)
tree473189e3323c1deb95b34c80a4af7f3f8fb0a32f /configure.in
parent2a7072a54111dd8d4679951572ce6098d5485c34 (diff)
[droid] fix build without alsa
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0c118a6e06..d535f6103d 100755
--- a/configure.in
+++ b/configure.in
@@ -921,6 +921,7 @@ if test "$target_platform" != "target_android" ; then
AC_CHECK_LIB([jasper], [main],, AC_MSG_ERROR($missing_library)) # check for cximage
AC_CHECK_LIB([rt], [clock_gettime],, AC_MSG_ERROR($missing_library))
fi
+if test "x$use_alsa" != "xno"; then
PKG_CHECK_MODULES([ALSA], [alsa],
[INCLUDES="$INCLUDES $ALSA_CFLAGS"; LIBS="$LIBS $ALSA_LIBS"; use_alsa=yes],
AC_MSG_NOTICE($alsa_not_found); use_alsa=no)
@@ -928,7 +929,7 @@ fi
[INCLUDES="$INCLUDES $DBUS_CFLAGS"; LIBS="$LIBS $DBUS_LIBS"; use_dbus=yes]; \
AC_DEFINE([HAVE_DBUS],[1],["Define to 1 if dbus is installed"]),
AC_MSG_NOTICE($missing_library); use_dbus=no)
-
+fi
if test "x$use_sdl" != "xno"; then
PKG_CHECK_MODULES([SDL], [sdl],
[INCLUDES="$INCLUDES $SDL_CFLAGS"; LIBS="$LIBS $SDL_LIBS"],