aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@svn>2010-05-12 05:26:38 +0000
committerdavilla <davilla@svn>2010-05-12 05:26:38 +0000
commit18edb2b4d24d54160782194eb32a54812539c74e (patch)
tree4cbcbe4396a34dcb25ec6e17c2fb0d9a1d786507 /configure.in
parent40805c671dfd17a64209b4a0ce0f2084f43b2f5c (diff)
[osx,linux] fixed build breakage
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@30038 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 754d9d5dd6..374d2dfa62 100644
--- a/configure.in
+++ b/configure.in
@@ -272,7 +272,7 @@ AC_ARG_ENABLE([external-python],
[use_external_python=$enableval],
[use_external_python=$use_external_libraries])
-USE_EXTERNAL_LIBASS=1
+use_external_libass="yes"
### End of external library options
@@ -319,7 +319,6 @@ if test "$host_vendor" = "apple" ; then
LDFLAGS="$LDFLAGS -L/opt/local/lib"
LDFLAGS="$LDFLAGS -L/opt/local/lib/mysql5/mysql"
LDFLAGS="$LDFLAGS -L/opt/local/lib/samba3"
- USE_EXTERNAL_LIBASS=0
fi
# Add top source directory for all builds so we can use config.h
@@ -449,7 +448,7 @@ else
AC_CHECK_LIB([tiff], [main],, AC_MSG_ERROR($missing_library))
AC_CHECK_LIB([rt], [clock_gettime],, AC_MSG_ERROR($missing_library))
AC_CHECK_LIB([SDL_image], [main],, AC_MSG_ERROR($missing_library))
- AC_CHECK_LIB([ass], [ass_set_message_cb],,USE_EXTERNAL_LIBASS=0)
+ AC_CHECK_LIB([ass], [ass_set_message_cb],,use_external_libass="no")
PKG_CHECK_MODULES([ALSA], [alsa],
[INCLUDES+=" $ALSA_CFLAGS"; LIBS+=" $ALSA_LIBS"],
@@ -1181,7 +1180,7 @@ if test "$host_vendor" = "apple"; then
xbmc/cores/paplayer/FLACCodec/Makefile"
fi
-if test $USE_EXTERNAL_LIBASS; then
+if test "$use_external_libass" = "no"; then
OUTPUT_FILES+=" \
lib/libass/xbmc/Makefile"
AC_DEFINE([USE_EXTERNAL_LIBASS], [1], [Whether to use external libass library.])],