aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortheuni <theuni-nospam-@xbmc.org>2011-08-13 04:31:31 -0400
committertheuni <theuni-nospam-@xbmc.org>2011-08-29 00:21:45 -0400
commiteb3b6c1d256929fefefe208c61cd59416e92fe53 (patch)
tree80257ddfa4eac4be020434ca87be62bc91dd5b93 /configure.in
parent21cce9ec76f326f9a02f8873773a978e3987bd4c (diff)
build: allow build without dbus
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 6b2baec518..18df0ba3e8 100644
--- a/configure.in
+++ b/configure.in
@@ -97,6 +97,7 @@ librtmp_disabled="== RTMP support disabled. =="
libnfs_not_found="== Could not find libnfs. NFS support disabled. =="
libnfs_disabled="== NFS support disabled. =="
alsa_not_found="== Could not find ALSA. ALSA support disabled. =="
+dbus_not_found="== Could not find DBUS. DBUS support disabled. =="
# External library message strings
@@ -687,9 +688,10 @@ else
PKG_CHECK_MODULES([ALSA], [alsa],
[INCLUDES="$INCLUDES $ALSA_CFLAGS"; LIBS="$LIBS $ALSA_LIBS"; use_alsa=yes],
AC_MSG_NOTICE($alsa_not_found); use_alsa=no)
- PKG_CHECK_MODULES([DBUS], [dbus-1],
- [INCLUDES="$INCLUDES $DBUS_CFLAGS"; LIBS="$LIBS $DBUS_LIBS"],
- AC_MSG_ERROR($missing_library))
+ PKG_CHECK_MODULES([DBUS], [dbus-1],
+ [INCLUDES="$INCLUDES $DBUS_CFLAGS"; LIBS="$LIBS $DBUS_LIBS"; use_dbus=yes]; \
+ AC_DEFINE([HAVE_DBUS],[1],["Define to 1 if dbus is installed"]),
+ AC_MSG_NOTICE($missing_library); use_dbus=no)
PKG_CHECK_MODULES([SDL], [sdl],
[INCLUDES="$INCLUDES $SDL_CFLAGS"; LIBS="$LIBS $SDL_LIBS"],
AC_MSG_ERROR($missing_library))
@@ -1243,6 +1245,12 @@ else
final_message="$final_message\n ALSA:\t\tNo"
fi
+if test "$use_dbus" = "yes"; then
+ final_message="$final_message\n DBUS:\t\tYes"
+else
+ final_message="$final_message\n DBUS:\t\tNo"
+fi
+
if test "x$use_vdpau" != "xno"; then
final_message="$final_message\n VDPAU:\tYes"
else