aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoramet <amet.nospam@gmail.com>2011-01-07 01:43:46 +0400
committeramet <amet.nospam@gmail.com>2011-01-07 01:43:46 +0400
commit646c49f9a35cf1f760519b358405d53bc701aea2 (patch)
treed9090ae22f9483ec489c67a3dc4e998e0fc9620a /configure.in
parent0931a156709c48d10ea0a8404e28a4643ae81641 (diff)
fixed: show Git revision number instead of SVN. commiting for TheUni
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 7 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index b387c61960..e7edf7efa8 100644
--- a/configure.in
+++ b/configure.in
@@ -1085,7 +1085,6 @@ if test "$ARCH" != "x86_64-linux"; then
fi
fi
-AC_CHECK_PROG(HAVE_SVNVERSION,svnversion,"yes","no",)
AC_CHECK_PROG(HAVE_GIT,git,"yes","no",)
# Checks for header files.
@@ -1258,23 +1257,16 @@ else
final_message="$final_message\n Avahi:\tNo"
fi
-if ! test -n "$SVN_REV" -a "$SVN_REV" != "" ; then
- if test "$HAVE_SVNVERSION" = "yes" ; then
- SVN_REV=$(svnversion -n -c 2>/dev/null | grep -iv ^exported | sed -e 's/.*\://')
- fi
- if test "$SVN_REV" = ""; then
- if test "$HAVE_GIT" = "yes"; then
- SVN_REV=$(./gitrev.sh)
- fi
- fi
- if test "$SVN_REV" = ""; then
- SVN_REV="Unknown"
- fi
+if test "$HAVE_GIT" = "yes"; then
+ GIT_REV=$(git rev-parse --short HEAD)
+fi
+if test "$GIT_REV" = ""; then
+ GIT_REV="Unknown"
fi
if test "$host_vendor" = "apple"; then
- echo "#define SVN_REV \"$SVN_REV\"" > svn_revision.h
+ echo "#define GIT_REV \"$GIT_REV\"" > git_revision.h
else
- SDL_DEFINES="$SDL_DEFINES -D'SVN_REV=\"$SVN_REV\"'"
+ SDL_DEFINES="$SDL_DEFINES -D'GIT_REV=\"$GIT_REV\"'"
fi
if test "$use_nonfree" = "yes"; then