aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortopfs2 <topfs2@svn>2010-11-21 17:35:54 +0000
committertopfs2 <topfs2@svn>2010-11-21 17:35:54 +0000
commit60cac8596a1b19bc7b2a6ce779e0aa419ac7df39 (patch)
tree2b4b498d5ce50d2e5366de136b07adccc401ac3f /configure.in
parent2a0518e33c1f1b26a86681d4e09f0846733cdf11 (diff)
Added a configure option --disable-optical-drive
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@35375 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 58bcc4d632..bf4cdfbdc3 100644
--- a/configure.in
+++ b/configure.in
@@ -249,6 +249,12 @@ AC_ARG_ENABLE([webserver],
[use_webserver=$enableval],
[use_webserver=yes])
+AC_ARG_ENABLE([optical-drive],
+ [AS_HELP_STRING([--disable-optical-drive],
+ [disable optical drive])],
+ [use_optical_drive=$enableval],
+ [use_optical_drive=yes])
+
AC_ARG_ENABLE([libdts],
[AS_HELP_STRING([--enable-libdts],
[enable deprecated libdts support])],
@@ -683,6 +689,11 @@ else
fi
fi
+# Optical
+if test "$use_optical_drive" = "yes"; then
+ AC_DEFINE([HAS_DVD_DRIVE], [1], [Define to 1 to have optical drive support])
+fi
+
# PulseAudio
if test "x$use_pulse" != "xno"; then
if test "$host_vendor" = "apple" ; then
@@ -1292,6 +1303,12 @@ else
final_message="$final_message\n libRTMP support:\tNo"
fi
+if test "$use_optical_drive" = "yes"; then
+ final_message="$final_message\n Optical drive:\tYes"
+else
+ final_message="$final_message\n Optical drive:\tNo"
+fi
+
if test "$use_libdts" = "yes"; then
USE_LIBDTS_DECODER=1
AC_DEFINE([USE_LIBDTS_DECODER], [1], [Define to 1 to enable deprecated libdts support])