aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartijn Kaijser <machine.sanctum@gmail.com>2013-10-27 00:48:34 -0700
committerMartijn Kaijser <machine.sanctum@gmail.com>2013-10-27 00:48:34 -0700
commit154a2613102c04c16f1e40e4267d1157736edfa8 (patch)
tree8f29e5211b5b22e9430f7864b3a6665c554c1a7e /configure.in
parent58d04ec77903d73f5dc41e402622d5c1566fb319 (diff)
parent502a6ad7497a8788519cf1d80ebb2fc76bf077c7 (diff)
Merge pull request #3458 from smspillaz/fix-14644-14645
Some simple wayland build fixes for newer mesa versions
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9c05933e03..294e30011e 100644
--- a/configure.in
+++ b/configure.in
@@ -975,7 +975,7 @@ if test "$use_wayland" = "yes" && test "$host_vendor" != "apple"; then
AC_MSG_ERROR($missing_library))
PKG_CHECK_MODULES([WAYLAND_EGL], [wayland-egl],
[INCLUDES="$INCLUDES $WAYLAND_EGL_CFLAGS";
- WAYLAND_EGL_LIBRARY_LINE=`LIBRARY=\`${PKG_CONFIG} --libs-only-l wayland-egl\`; echo ${LIBRARY:2}`
+ WAYLAND_EGL_LIBRARY_LINE=`LIBRARY=\`${PKG_CONFIG} --libs-only-l wayland-egl\`; echo ${LIBRARY:2:11}`
XB_FIND_SONAME([WAYLAND_EGL_LIBRARY], ${WAYLAND_EGL_LIBRARY_LINE})],
AC_MSG_ERROR($missing_library))
PKG_CHECK_MODULES([XKBCOMMON], [xkbcommon],