aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTrent Nelson <trent.a.b.nelson@gmail.com>2014-02-10 15:35:05 -0700
committerTrent Nelson <trent.a.b.nelson@gmail.com>2014-02-10 15:35:05 -0700
commit294972696f232dca7322cb7673a33da255aa1dd3 (patch)
tree7758486c1e472dee40d62622114f98eb8078d827 /configure.in
parent195a6b669e259c5355629a8a3ddcd7abe07a4994 (diff)
parent2449e6e6cf3ce3acfed2c084aae4ed1ce768aa1a (diff)
Merge pull request #4099 from vkosh/configure-git
[configure] get git revision from xbmc git root
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 808f74bdcf..9b9c36c7cc 100644
--- a/configure.in
+++ b/configure.in
@@ -757,7 +757,7 @@ AC_CHECK_PROG(HAVE_GIT,git,"yes","no",)
if test "$GIT_REV" = ""; then
if test -f VERSION ; then
GIT_REV=$(awk 'END{print substr($1,1,16)}' VERSION)
- elif test "$HAVE_GIT" = "yes"; then
+ elif test "$HAVE_GIT" = "yes" -a -d $(abs_top_srcdir)/.git; then
GIT_REV=$(git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h %ci" HEAD | awk '{gsub("-", "");print $2"-"$1}')
else
GIT_REV="Unknown"