aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJonathan Marshall <jmarshall@xbmc.org>2014-05-05 08:45:49 +1200
committerJonathan Marshall <jmarshall@xbmc.org>2014-05-05 08:45:49 +1200
commitb237030e1ed5d6a983aa17b1c0bf35a42ccc77f4 (patch)
tree9230a4864fe51bfacfa52c835c422dc6c449caf3 /configure.in
parent0d1d80373801c330e2a5dc938cc50d0d6d3ccc6d (diff)
Revert "Merge pull request #4642 from wsnipex/linking-fix"
This reverts commit 0d1d80373801c330e2a5dc938cc50d0d6d3ccc6d, reversing changes made to 60bd97bdd8d662807076e9838ad7632b8c92d4fa.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 14 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index f3e142f26b..d8d06df226 100644
--- a/configure.in
+++ b/configure.in
@@ -880,7 +880,6 @@ if test "$use_static_ffmpeg" = "yes"; then
# ffmpeg may depend on gnutls and vorbisenc, we add those libs at the end of linker
# command in order to resolve any missing symbols
GNUTLS_ALL_LIBS=`${PKG_CONFIG} --static --libs-only-l --silence-errors gnutls`
- HOGWEED_ALL_LIBS=`${PKG_CONFIG} --static --libs-only-l --silence-errors hogweed nettle`
VORBISENC_ALL_LIBS=`${PKG_CONFIG} --static --libs-only-l --silence-errors vorbisenc`
fi
@@ -1529,26 +1528,20 @@ fi
# libRTMP
if test "$use_librtmp" != "no"; then
- PKG_CHECK_MODULES([LIBRTMP], [librtmp],
- [INCLUDES="$INCLUDES $LIBRTMP_CFLAGS"; LIBS="$LIBS $LIBRTMP_LIBS";
- AC_DEFINE([HAS_LIBRTMP], [1], [Whether to use libRTMP library.])
- RTMP_ALL_LIBS=$(${PKG_CONFIG} --static --libs-only-l --silence-errors librtmp)
- test "$use_static_ffmpeg" = "yes" && LIBS="$LIBS $RTMP_ALL_LIBS"],
- [AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],,
- [if test "$use_librtmp" = "yes"; then
- AC_MSG_ERROR($librtmp_not_found)
- elif test "$use_librtmp" != "no"; then
- AC_MSG_NOTICE($librtmp_not_found)
- use_librtmp="no"
- fi
- ])
- if test "$use_librtmp" != "no"; then
- XB_FIND_SONAME([RTMP], [rtmp], [use_librtmp])
- fi
- if test "$use_librtmp" != "no"; then
- AC_DEFINE([HAS_LIBRTMP], [1], [Whether to use libRTMP library.])
- fi
- ])
+ AC_CHECK_HEADERS([librtmp/log.h librtmp/amf.h librtmp/rtmp.h],,
+ [if test "$use_librtmp" = "yes"; then
+ AC_MSG_ERROR($librtmp_not_found)
+ elif test "$use_librtmp" != "no"; then
+ AC_MSG_NOTICE($librtmp_not_found)
+ use_librtmp="no"
+ fi
+ ])
+ if test "$use_librtmp" != "no"; then
+ XB_FIND_SONAME([RTMP], [rtmp], [use_librtmp])
+ fi
+ if test "$use_librtmp" != "no"; then
+ AC_DEFINE([HAS_LIBRTMP], [1], [Whether to use libRTMP library.])
+ fi
else
AC_MSG_NOTICE($librtmp_disabled)
fi
@@ -2674,7 +2667,6 @@ AC_SUBST(GTEST_CONFIGURED)
AC_SUBST(USE_DOXYGEN)
AC_SUBST(USE_PVR_ADDONS)
AC_SUBST(GNUTLS_ALL_LIBS)
-AC_SUBST(HOGWEED_ALL_LIBS)
AC_SUBST(VORBISENC_ALL_LIBS)
# pushd and popd are not available in other shells besides bash, so implement