aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFneufneu <fneufneu@xbmc.org>2012-10-01 16:43:06 +0200
committerFneufneu <fneufneu@xbmc.org>2012-10-01 16:43:06 +0200
commitced6980164184f67e9cc224ef61458c5a5facfb1 (patch)
treede235782b8f8b9eafe376e42bb1e91f7bc1ad339 /configure.in
parentecd9c59389bf112e437f3423079be8ec2829d852 (diff)
add a check for swig2.0 binary
we need to check with another var SWIG20_EXE because AC_PATH_PROG cache the result on his first parameter
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8e22960a86..29bcc62d84 100644
--- a/configure.in
+++ b/configure.in
@@ -1586,6 +1586,12 @@ fi
echo "Checking for SWIG installation"
AC_PATH_PROG(SWIG_EXE, swig, "none")
if test "$SWIG_EXE" = "none"; then
+ AC_CHECK_PROG(SWIG20_EXE, swig2.0, , "none")
+ if test "$SWIG20_EXE" != "none" ; then
+ SWIG_EXE=$SWIG20_EXE
+ fi
+fi
+if test "$SWIG_EXE" = "none"; then
AC_MSG_ERROR($missing_program)
fi
final_message="$final_message\n SWIG Available:\tYes"