aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChris Roberts <croberts@bongle.co.uk>2012-07-04 00:32:20 +0800
committerChris Roberts <croberts@bongle.co.uk>2012-09-10 19:23:38 +0800
commit381b16455997c1f2224dcd0cc20453ad2510f975 (patch)
tree4f314aced8fba4f608798b3c704e3ac111605ead /configure.in
parentd748cb5bdd9df1a401d32599464c47c3480f7073 (diff)
[tags] Add Makefile and taglib dependency, add taglib to xcode, android, linux and win32 depends
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 933e76ed77..85bf004dc7 100644
--- a/configure.in
+++ b/configure.in
@@ -970,6 +970,9 @@ PKG_CHECK_MODULES([SAMPLERATE], [samplerate],
PKG_CHECK_MODULES([FREETYPE2], [freetype2],
[INCLUDES="$INCLUDES $FREETYPE2_CFLAGS"; LIBS="$LIBS $FREETYPE2_LIBS"],
AC_MSG_ERROR($missing_library))
+PKG_CHECK_MODULES([TAGLIB], [taglib >= 1.8],
+ [INCLUDES="$INCLUDES $TAGLIB_CFLAGS"; LIBS="$LIBS $TAGLIB_LIBS"],
+ AC_MSG_ERROR($missing_library))
if test "$target_platform" = "target_android" ; then
PKG_CHECK_MODULES([ZIP], [libzip],