aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Hochecker <fernetmenta@online.de>2016-07-01 06:42:37 +0200
committerGitHub <noreply@github.com>2016-07-01 06:42:37 +0200
commit4a635240ae5a6a3a03750efba0f30b65b5de7c2d (patch)
treee664131972284d2a3042b0b3779d5817ad72f376 /configure.ac
parent630142a9b948ebfdff8ada51b8519521fc49eb65 (diff)
parent94299590ff6babcbe29330da78f8a55531817fcc (diff)
Merge pull request #9731 from laurimyllari/v17-3dlut
3dlut and simple ICC linking support for color correction
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a0d3ec31c..d498f958b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -208,6 +208,9 @@ libusb_disabled="== libusb disabled. Plug and play USB device support will not b
libusb_disabled_udev_found="== libusb disabled. =="
libcec_enabled="== libcec enabled. =="
libcec_disabled="== libcec disabled. CEC adapter support will not be available. =="
+lcms2_enabled="== lcms2 enabled. =="
+lcms2_not_found="== Could not find lcms2. ICC profile support will not be available. =="
+lcms2_disabled="== lcms2 disabled. ICC profile support will not be available. =="
libbluetooth_not_found="== Could not find libbluetooth. Bluetooth support will not be available =="
libbluetooth_enabled="== libbluetooth enabled. =="
libbluetooth_disabled="== libbluetooth disabled. Bluetooth support will not be available. =="
@@ -442,6 +445,12 @@ AC_ARG_ENABLE([libcec],
[use_libcec=$enableval],
[use_libcec=auto])
+AC_ARG_ENABLE([lcms2],
+ [AS_HELP_STRING([--enable-lcms2],
+ [enable lcms2 support (default is auto)])],
+ [use_lcms2=$enableval],
+ [use_lcms2=auto])
+
AC_ARG_ENABLE([libbluetooth],
[AS_HELP_STRING([--enable-libbluetooth],
[enable libbluetooth support (default is auto)])],
@@ -1444,6 +1453,21 @@ else
AC_MSG_NOTICE($libcec_disabled)
fi
+# lcms2
+if test "$use_lcms2" = "auto"; then
+ PKG_CHECK_MODULES([LCMS2],[lcms2],,[use_lcms2="no";AC_MSG_RESULT($lcms2_not_found)])
+elif test "$use_lcms2" = "yes" ; then
+ PKG_CHECK_MODULES([LCMS2],[lcms2],,[use_lcms2="no";AC_MSG_ERROR($lcms2_not_found)])
+else
+ AC_MSG_NOTICE($lcms2_disabled)
+fi
+
+if test "x$use_lcms2" != "xno"; then
+ USE_LCMS2=1;INCLUDES="$INCLUDES $LCMS2_CFLAGS";LIBS="$LIBS $LCMS2_LIBS"
+ AC_DEFINE([HAVE_LCMS2],[1],["Define to 1 if lcms2 is installed"])
+ AC_MSG_NOTICE($lcms2_enabled)
+fi
+
# libbluetooth
USE_LIBBLUETOOTH=0
if test "$use_libbluetooth" = "auto"; then
@@ -2074,6 +2098,12 @@ else
final_message="$final_message\n libcec support:\tNo"
fi
+if test "x$use_lcms2" != "xno"; then
+ final_message="$final_message\n lcms2 support:\tYes"
+else
+ final_message="$final_message\n lcms2 support:\tNo"
+fi
+
if test "x$use_libbluetooth" != "xno"; then
final_message="$final_message\n libbluetooth support:\tYes"
else