aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2016-10-15 16:47:54 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2016-10-16 11:50:55 +0200
commit875389f88dd494af3d9372244b1043e5a57ac23a (patch)
tree07e1c4deb55a556950a55e2843e777fb84c21947 /configure.ac
parentb66ef50b5086897f02a9b491631804425cf0b406 (diff)
configure: fix aarch64 builds
Just like x86* aarch64 has platforms that can be full openGL and/or full openGLES. In the case of mesa/freedreno on Qualcomm SoCs, building against GLES will fail, but full GL works. So stop hardcoding GL/GLES/Wayland and let honour the --enable-gl flags passed to configure. If no --enable-gl flag is present, fall back to GLES. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1bf98a46c9..0560a12b9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,9 +626,13 @@ case $host in
ARCH="aarch64"
use_arch="aarch64"
use_neon=yes
- use_gles=yes
- use_gl=no
- use_wayland=no
+ # Check whether --enable-gl was given.
+ if test "${enable_gl+set}" = set; then :
+ enableval=$enable_gl; use_gl=$enableval
+ else
+ use_gl=no
+ use_gles=yes
+ fi
USE_STATIC_FFMPEG=1
;;
arm*-*linux-android*)