aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartijn Kaijser <martijn@xbmc.org>2015-04-26 11:37:35 +0200
committerMartijn Kaijser <martijn@xbmc.org>2015-04-26 11:37:35 +0200
commit008d4637abc035f14d96019098c09e299d9c15d4 (patch)
tree1a6a03b0383457e5407478902fb849217de5fb61 /configure.ac
parent81d04596960e28918f0360f25073cc5f4d2ddf54 (diff)
parent0e243bc650551cc8f9892fd38ba4f60f7ce5b103 (diff)
Merge pull request #6897 from wsnipex/kodi-config
[binary addons] use correct library install paths on different linux distros
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7b2a871ff..ea94c1d2c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2590,6 +2590,18 @@ OUTPUT_FILES="$OUTPUT_FILES \
xbmc/interfaces/python/Makefile \
xbmc/interfaces/python/test/Makefile"
+# needed for kodi-config.cmake
+if echo "$libdir" | grep -q '${exec_prefix}'; then
+ if test "${prefix}" = "NONE" || test "${prefix}" = ""; then
+ prefix="/usr/local"
+ fi
+ if test "${exec_prefix}" = "NONE" || test "${exec_prefix}" = ""; then
+ exec_prefix=${prefix}
+ fi
+fi
+eval "APP_LIBDIR=${libdir}"
+AC_SUBST(APP_LIBDIR)
+
# Line below is used so we can use AM_INIT_AUTOMAKE. The corresponding
# .dummy.am does nothing.
AC_CONFIG_FILES([.dummy])