aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2016-10-11 20:38:41 +0200
committerwsnipex <wsnipex@a1.net>2016-10-13 14:16:22 +0200
commitae06a53de5bd2f0596f46e177d089773983b068a (patch)
tree826ff9456ae2b5f41cbf09579725be68233555ae /configure.ac
parent807f71865b897081f4c89653b2e674f9f245421d (diff)
[android] don't strip binaries in debug builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6a8b4a26a5..1bf98a46c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -719,6 +719,7 @@ fi
# platform debug flags
if test "$use_debug" = "yes"; then
+ CMAKE_BUILD_TYPE="Debug"
final_message="$final_message\n Debugging:\tYes"
if test "$use_profiling" = "yes"; then
final_message="$final_message\n Profiling:\tYes"
@@ -728,6 +729,7 @@ if test "$use_debug" = "yes"; then
DEBUG_FLAGS="-g -D_DEBUG -Wall"
fi
else
+ CMAKE_BUILD_TYPE="Release"
final_message="$final_message\n Debugging:\tNo"
if test "$use_profiling" = "yes"; then
final_message="$final_message\n Profiling:\tYes"
@@ -2268,6 +2270,8 @@ OUTPUT_FILES="$OUTPUT_FILES \
.dummy"
AC_SUBST(CORE_SYSTEM_NAME)
AC_SUBST(CORE_SYSTEM_VARIANT)
+AC_SUBST(CROSS_COMPILING)
+AC_SUBST(CMAKE_BUILD_TYPE)
AC_SUBST(CFLAGS)
AC_SUBST(CXXFLAGS)
AC_SUBST(INCLUDES)
@@ -2321,7 +2325,6 @@ AC_SUBST(HAVE_SSE4)
AC_SUBST(USE_MMAL)
AC_SUBST(USE_X11)
AC_SUBST(USE_OPTICAL_DRIVE)
-AC_SUBST(CROSS_COMPILING)
# pushd and popd are not available in other shells besides bash, so implement
# our own pushd/popd functions