aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Hochecker <fernetmenta@online.de>2016-04-29 09:20:45 +0200
committerRainer Hochecker <fernetmenta@online.de>2016-04-29 09:20:45 +0200
commitebefcd0c62689579b6c013e5d1b32f58cea23b37 (patch)
treead03b2562df9c7d4c12122c64e589e2fd0f6a93a /configure.ac
parent84284a877734d775b1bc541b2b4264ad5bc1cf14 (diff)
VideoPlayer: iOS, drop old videotoolbox decoder infaviour of ffmpeg
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 9 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index 39b1c15338..1e0d44a24b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,7 +84,7 @@ AC_DEFUN([XB_FIND_SONAME],
for path in $gcc_lib_path $env_lib_path $host_lib_path; do
lib=[`ls -- $path/lib$2.dylib 2>/dev/null`]
if test x$lib != x; then
- # we want the path/name that is embedded in the dylib
+ # we want the path/name that is embedded in the dylib
$1_FILENAME=[`otool -L $lib | grep -v lib$2.dylib | grep lib$2 | awk '{V=1; print $V}'`]
$1_SONAME=[`basename $$1_FILENAME`]
fi
@@ -184,8 +184,6 @@ vdpau_not_found="== Could not find libvdpau. VDPAU support disabled. =="
vdpau_disabled="== VDPAU support manually disabled. =="
vaapi_not_found="== Could not find libva. VAAPI support disabled. =="
vaapi_disabled="== VAAPI support manually disabled. =="
-vtbdecoder_enabled="== VTBDecoder support enabled. =="
-vtbdecoder_disabled="== VTBDecoder support manually disabled. =="
openmax_disabled="== OpenMax support manually disabled. =="
openmax_not_found="== Could not find OpenMax headers. OpenMax support disabled. =="
librtmp_not_found="== Could not find libRTMP. RTMP support disabled. =="
@@ -271,12 +269,6 @@ AC_ARG_ENABLE([vaapi],
[use_vaapi=$enableval],
[use_vaapi=auto])
-AC_ARG_ENABLE([vtbdecoder],
- [AS_HELP_STRING([--enable-vtbdecoder],
- [enable VTBDecoder decoding (default is auto)])],
- [use_vtbdecoder=$enableval],
- [use_vtbdecoder=auto])
-
AC_ARG_ENABLE([openmax],
[AS_HELP_STRING([--enable-openmax],
[enable OpenMax decoding (default is auto, requires OpenGLES)])],
@@ -378,7 +370,7 @@ AC_ARG_ENABLE([avahi],
[disable Avahi support (default is enabled if libavahi-common and libavahi-client is found)])],
[use_avahi=$enableval],
[use_avahi=yes])
-
+
AC_ARG_ENABLE([mdnsembedded],
[AS_HELP_STRING([--disable-mdnsembedded],
[disable mDNSEmbedded support (default is auto)])],
@@ -533,7 +525,7 @@ case $host in
use_gles=yes
use_optical_drive=no
use_x11=no
- build_shared_lib=yes
+ build_shared_lib=yes
;;
i*86*-linux-gnu*|i*86*-*-linux-uclibc*)
target_platform=target_linux
@@ -584,7 +576,6 @@ case $host in
CORE_SYSTEM_NAME=ios
use_neon=yes
use_libcec=no
- use_vtbdecoder=yes
use_optical_drive=no
use_gles=yes
use_cpu=cortex-a8
@@ -600,14 +591,12 @@ case $host in
;;
*86*-apple-darwin*)
CORE_SYSTEM_NAME=osx
- use_vtbdecoder=no
ARCH="x86-osx"
DEPENDS_ROOT_FOR_XCODE=$(echo ${prefix%/*})
AC_SUBST([DEPENDS_ROOT_FOR_XCODE])
;;
powerpc-apple-darwin*)
CORE_SYSTEM_NAME=osx
- use_vtbdecoder=no
ARCH="powerpc-osx"
use_arch="ppc"
DEPENDS_ROOT_FOR_XCODE=$(echo ${prefix%/*})
@@ -793,7 +782,7 @@ elif test "$use_arch" = "arm"; then
CFLAGS="$CFLAGS -mno-apcs-stack-check"
CXXFLAGS="$CXXFLAGS -mno-apcs-stack-check"
if test "$use_tegra" = "yes"; then
- # Compile for ARMv7a architecture, need to test gcc for vfpv3-d16 support
+ # Compile for ARMv7a architecture, need to test gcc for vfpv3-d16 support
SAVE_CFLAGS="$CFLAGS"
CFLAGS="-mfpu=vfpv3-d16"
AC_COMPILE_IFELSE(
@@ -802,10 +791,10 @@ elif test "$use_arch" = "arm"; then
CXXFLAGS="$CXXFLAGS -Wno-psabi -Wa,-march=armv7a -mtune=cortex-a9 -mfpu=vfpv3-d16 -mthumb-interwork"
use_cpu=cortex-a9],
[ CFLAGS="$SAVE_CFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
- CXXFLAGS="$CXXFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
+ CXXFLAGS="$CXXFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
use_cpu=cortex-a8])
else
- if test "$use_neon" = "yes"; then
+ if test "$use_neon" = "yes"; then
CFLAGS="$CFLAGS -mfpu=neon -mvectorize-with-neon-quad"
CXXFLAGS="$CXXFLAGS -mfpu=neon -mvectorize-with-neon-quad"
fi
@@ -1578,7 +1567,7 @@ fi
if test "$FFMPEG_FOUND" != "true"; then
PKG_CHECK_MODULES([FFMPEG], [$FFMPEG_LIBNAMES],
- [INCLUDES="$INCLUDES $FFMPEG_CFLAGS"; LIBS="$LIBS $FFMPEG_LIBS"; FFMPEG_FOUND="true"],
+ [INCLUDES="$INCLUDES $FFMPEG_CFLAGS"; LIBS="$LIBS $FFMPEG_LIBS"; FFMPEG_FOUND="true"],
[AC_MSG_ERROR("ffmpeg not found")])
fi
@@ -1687,24 +1676,6 @@ else
USE_VAAPI=0
fi
-# VTBDecoder
-if test "x$use_vtbdecoder" != "xno"; then
- if test "$host_vendor" = "apple" ; then
- HAVE_VIDEOTOOLBOXDECODER=1
- AC_DEFINE([HAVE_VIDEOTOOLBOXDECODER], [1], [Define to 1 if you have the 'VTBDecoder' library.])
- AC_MSG_NOTICE($vtbdecoder_enabled)
- else
- if test "x$use_vtbdecoder" = "xyes"; then
- AC_MSG_ERROR([VTB Decoder not supported on this platform])
- else
- use_vtbdecoder="no"
- AC_MSG_NOTICE($vtbdecoder_disabled)
- fi
- fi
-else
- AC_MSG_NOTICE($vtbdecoder_disabled)
-fi
-
# OpenMax
if test "$use_gles" = "yes" && test "$use_openmax" = "auto"; then
@@ -1886,12 +1857,6 @@ else
final_message="$final_message\n VAAPI:\tNo"
fi
-if test "x$use_vtbdecoder" != "xno"; then
- final_message="$final_message\n VTBDecoder:\tYes"
-else
- final_message="$final_message\n VTBDecoder:\tNo"
-fi
-
if test "$use_openmax" != "no"; then
final_message="$final_message\n OpenMax:\tYes"
else
@@ -2073,7 +2038,7 @@ else
fi
if test "x$use_airtunes" != "xno"; then
- final_message="$final_message\n AirTunes support (libshairplay):\tYes"
+ final_message="$final_message\n AirTunes support (libshairplay):\tYes"
else
final_message="$final_message\n AirTunes support:\tNo"
fi
@@ -2387,7 +2352,7 @@ XB_CONFIG_MODULE([lib/cpluff], [
--host=$host_alias \
--build=$build_alias \
--target=$target_alias CFLAGS="$CFLAGS" CC="$CC" CXX="$CXX" LDFLAGS="$LDFLAGS" LIBS=""
- #LDFLAGS="$LDFLAGS -Wl,-read_only_relocs,suppress"
+ #LDFLAGS="$LDFLAGS -Wl,-read_only_relocs,suppress"
], [0])
XB_CONFIG_MODULE([lib/gtest], [