aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2015-03-22 13:01:34 +0100
committerwsnipex <wsnipex@a1.net>2015-03-22 13:01:34 +0100
commitb641e1eea54b4b9ab7f1b95092ab0a755abc63be (patch)
treec7d847ee5ddecd545b5abe2e7797e60f2492c706 /configure.ac
parent34373f97e82d33c108fca457de5e31fb973de954 (diff)
[configure] add option to disable lirc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b377e8c1d2..8a5b760747 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,6 +500,12 @@ AC_ARG_ENABLE([texturepacker],
[use_texturepacker=$enableval],
[use_texturepacker=auto])
+AC_ARG_ENABLE([lirc],
+ [AS_HELP_STRING([--disable-lirc],
+ [disable lirc support (default is enabled)])],
+ [AC_MSG_RESULT("Lirc disabled")],
+ [AC_DEFINE([HAVE_LIRC], [1], ["Lirc enabled"])])
+
AC_ARG_WITH([lirc-device],
[AS_HELP_STRING([--with-lirc-device=file],
[specify the default LIRC device (default is /dev/lircd)])],