aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2015-04-06 14:21:40 +0200
committerwsnipex <wsnipex@a1.net>2015-04-09 11:02:27 +0200
commitd30fb060bda2981e34d49a8108509ab192939e31 (patch)
tree784d9d2a188517f543004821e840181c889dcf4e /configure.ac
parentd99ca917893706a01d08125ccb7a6dea4f4cae26 (diff)
[configure] properly set multi arch kodi libdir in kodi-config.cmake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb7c7829b8..94ccc225ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2589,6 +2589,18 @@ OUTPUT_FILES="$OUTPUT_FILES \
xbmc/interfaces/python/Makefile \
xbmc/interfaces/python/test/Makefile"
+# needed for kodi-config.cmake
+if echo "$libdir" | grep -q '${exec_prefix}'; then
+ if test "${prefix}" = "NONE" || test "${prefix}" = ""; then
+ prefix="/usr/local"
+ fi
+ if test "${exec_prefix}" = "NONE" || test "${exec_prefix}" = ""; then
+ exec_prefix=${prefix}
+ fi
+fi
+eval "APP_LIBDIR=${libdir}"
+AC_SUBST(APP_LIBDIR)
+
# Line below is used so we can use AM_INIT_AUTOMAKE. The corresponding
# .dummy.am does nothing.
AC_CONFIG_FILES([.dummy])