aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjenkins4kodi <jenkins4kodi@users.noreply.github.com>2016-09-18 01:32:16 +0200
committerGitHub <noreply@github.com>2016-09-18 01:32:16 +0200
commitcc9c142c653f5a77a6daf347d3bd6ed6d586f667 (patch)
tree6022920104230e3c212332a6155db2a26cd437f4 /configure.ac
parentc6a62cfa854db440303546b4866ad823c2ab1d56 (diff)
parentf0b1c5b814ca26dbd866ca3907e178e3240d434b (diff)
Merge pull request #10473 from Memphiz/fix_sse_osx
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3334490ab5..acf4ce6474 100644
--- a/configure.ac
+++ b/configure.ac
@@ -762,6 +762,21 @@ if test "$host_vendor" = "apple" ; then
# standard application paths
INCLUDES="$INCLUDES -I\$(abs_top_srcdir)/xbmc/osx"
if test "$use_arch" != "arm"; then
+ SAVE_CFLAGS="$CFLAGS"
+ CFLAGS="-msse -msse2"
+ AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE([int foo;])],
+ [ HAVE_SSE=1
+ HAVE_SSE2=1
+ AC_DEFINE([HAVE_SSE],[1],[sse enabled])
+ AC_DEFINE([HAVE_SSE2],[1],[sse2 enabled])],
+ [ HAVE_SSE=0
+ HAVE_SSE2=0
+ AC_DEFINE([HAVE_SSE],[0],[sse enabled])
+ AC_DEFINE([HAVE_SSE2],[0],[sse2 enabled])
+ ])
+ CFLAGS="$SAVE_CFLAGS"
+
LIBS="$LIBS -framework ApplicationServices"
LIBS="$LIBS -framework AudioUnit"
LIBS="$LIBS -framework AudioToolbox"