aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLauri Myllari <lauri.myllari@gmail.com>2016-05-01 12:52:25 -0700
committerLauri Myllari <lauri.myllari@gmail.com>2016-06-20 14:22:36 -0700
commita4a776a5042e86a0a719d90b3688a2eb0f5033f6 (patch)
treef8684be8088e1e663f464dc5c834bdb3df106be3 /configure.ac
parente8e6c2a8e52632245dca2b9d0c765935c4feeeeb (diff)
color: ColorManager class and settings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8cc0ba8d8b..174c57c279 100644
--- a/configure.ac
+++ b/configure.ac
@@ -208,6 +208,9 @@ libusb_disabled="== libusb disabled. Plug and play USB device support will not b
libusb_disabled_udev_found="== libusb disabled. =="
libcec_enabled="== libcec enabled. =="
libcec_disabled="== libcec disabled. CEC adapter support will not be available. =="
+lcms2_enabled="== lcms2 enabled. =="
+lcms2_not_found="== Could not find lcms2. ICC profile support will not be available. =="
+lcms2_disabled="== lcms2 disabled. ICC profile support will not be available. =="
libbluetooth_not_found="== Could not find libbluetooth. Bluetooth support will not be available =="
libbluetooth_enabled="== libbluetooth enabled. =="
libbluetooth_disabled="== libbluetooth disabled. Bluetooth support will not be available. =="
@@ -442,6 +445,12 @@ AC_ARG_ENABLE([libcec],
[use_libcec=$enableval],
[use_libcec=auto])
+AC_ARG_ENABLE([lcms2],
+ [AS_HELP_STRING([--enable-lcms2],
+ [enable lcms2 support (default is auto)])],
+ [use_lcms2=$enableval],
+ [use_lcms2=auto])
+
AC_ARG_ENABLE([libbluetooth],
[AS_HELP_STRING([--enable-libbluetooth],
[enable libbluetooth support (default is auto)])],
@@ -1444,6 +1453,21 @@ else
AC_MSG_NOTICE($libcec_disabled)
fi
+# lcms2
+if test "$use_lcms2" = "auto"; then
+ PKG_CHECK_MODULES([LCMS2],[lcms2],,[use_lcms2="no";AC_MSG_RESULT($lcms2_not_found)])
+elif test "$use_lcms2" = "yes" ; then
+ PKG_CHECK_MODULES([LCMS2],[lcms2],,[use_lcms2="no";AC_MSG_ERROR($lcms2_not_found)])
+else
+ AC_MSG_NOTICE($lcms2_disabled)
+fi
+
+if test "x$use_lcms2" != "xno"; then
+ USE_LCMS2=1;INCLUDES="$INCLUDES $LCMS2_CFLAGS";LIBS="$LIBS $LCMS2_LIBS"
+ AC_DEFINE([HAVE_LCMS2],[1],["Define to 1 if lcms2 is installed"])
+ AC_MSG_NOTICE($lcms2_enabled)
+fi
+
# libbluetooth
USE_LIBBLUETOOTH=0
if test "$use_libbluetooth" = "auto"; then
@@ -2074,6 +2098,12 @@ else
final_message="$final_message\n libcec support:\tNo"
fi
+if test "x$use_lcms2" != "xno"; then
+ final_message="$final_message\n lcms2 support:\tYes"
+else
+ final_message="$final_message\n lcms2 support:\tNo"
+fi
+
if test "x$use_libbluetooth" != "xno"; then
final_message="$final_message\n libbluetooth support:\tYes"
else