aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2015-10-22 16:20:56 +0200
committerwsnipex <wsnipex@a1.net>2015-10-23 14:31:17 +0200
commit94faa07c8134e70e0dfb54a2da9367455a79ac6a (patch)
treef160676d00c4164ad3a4920ad767c24b6f92dd61 /configure.ac
parent98b7d16fba57cc66e6c1a35dd6212e90e61a6f9d (diff)
[depends] crossguid: use libuuid on droid
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fd5ab126ff..7981e8dad2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1125,7 +1125,7 @@ int main() {
)])
AC_LANG_POP([C++])
-if test "${target_platform}" = "target_linux" || test "${target_platform}" = "target_raspberry_pi"; then
+if test "${target_platform}" = "target_linux" || test "${target_platform}" = "target_raspberry_pi" || test "${target_platform}" = "target_android"; then
PKG_CHECK_MODULES([UUID], [uuid],, AC_MSG_ERROR(libuuid not found))
fi
@@ -1141,9 +1141,6 @@ AC_LINK_IFELSE(
[AC_MSG_ERROR(crossguid not found)])
LIBS="$SAVED_LIBS"
AC_LANG_POP([C++])
-if test "${target_platform}" = "target_android"; then
- CXXFLAGS="$CXXFLAGS -DGUID_ANDROID"
-fi
PKG_CHECK_MODULES([YAJL], [yajl >= 2],
[INCLUDES="$INCLUDES $YAJL_CFLAGS"; LIBS="$LIBS $YAJL_LIBS"; YAJL_FOUND="true"],